What did you do to your GMT today?

Status
Not open for further replies.

Sparky

Member
Dec 4, 2011
12,927
I've noticed my truck has been slow cranking when cold lately. Has a 3 year old ish NAPA AGM in it. I'm wondering if there's an issue with it or if the factory original starter is just getting old and tired.

Oh, the Dorman exterior driver door handle I put on it broke at the hinge similar to the factory one, difference being the dorman was only a couple of years old vs 11 years for the original. Blah. Whatever, it still opens the door, but I ain't using them again if I need another one.
 
  • Sad
Reactions: Matt

Mike534x

Member
Apr 9, 2012
994
Received the purge kit and new thermostat, looks like I'm putting this off for a few days. Not sure if I got a fake AC Delco T-Stat, or what but the one in the box is a Motorad one (its stamped on the housing) but in an authentic box with GM part #. Only one Amazon had let me exchange it with was a Stant one in my cart, which isn't a biggie. I would trust that over the garbage Motorad one.
 
  • Like
Reactions: Matt and Mooseman

Mooseman

Moderator
Dec 4, 2011
25,649
Ottawa, ON
Received the purge kit and new thermostat, looks like I'm putting this off for a few days. Not sure if I got a fake AC Delco T-Stat, or what but the one in the box is a Motorad one (its stamped on the housing) but in an authentic box with GM part #. Only one Amazon had let me exchange it with was a Stant one in my cart, which isn't a biggie. I would trust that over the garbage Motorad one.
As best as my research could show, the ACDelco are (or were) made by Mahle/Clevite, both with the crinkle bent pipe. I got the Mahle for my 07 since it was cheaper and it's been running mint. Oddly enough, RA isn't showing an ACDelco anymore.
 
  • Like
Reactions: Matt

Mike534x

Member
Apr 9, 2012
994
As best as my research could show, the ACDelco are (or were) made by Mahle/Clevite, both with the crinkle bent pipe. I got the Mahle for my 07 since it was cheaper and it's been running mint. Oddly enough, RA isn't showing an ACDelco anymore.
That's really bizarre. I went off the part number from RA, which matched the one I ordered about 4 years ago when I did the TB and I don't recall Motorad being stamped on that one either. It must be a recent change, because I'm seeing comments as of two years ago from users claiming to be receiving Motorad ones in the box, instead of the Delco branded ones. Are the thermostats typically universal among the 5.3's? I was about to order one for a 05 Yukon if they didn't have the Gates or Stant one in stock.
 

Attachments

  • IMG_20201228_231234.jpg
    IMG_20201228_231234.jpg
    301.5 KB · Views: 3

Mooseman

Moderator
Dec 4, 2011
25,649
Ottawa, ON
Oh, right, the 5.3. :Banghead: Yeah, forget what I said. I have no clue on those except maybe to say quite possibly ACDelco has switched supplier. I'd send it back and just say it's the wrong part inside the box. Maybe ACDelco will get the message. The other thing I do know is that the t-stat changed at some year where you also need to change the housing if you replace it. I'd say you're safe if you get a same year one for any other LS engine truck.
 
  • Like
Reactions: Mike534x

Mike534x

Member
Apr 9, 2012
994
Oh, right, the 5.3. :Banghead: Yeah, forget what I said. I have no clue on those except maybe to say quite possibly ACDelco has switched supplier. I'd send it back and just say it's the wrong part inside the box. Maybe ACDelco will get the message. The other thing I do know is that the t-stat changed at some year where you also need to change the housing if you replace it. I'd say you're safe if you get a same year one for any other LS engine truck.

That was my thinking as well, I'm sending this one back and getting a stant instead. I figured it should work if it came from the same year engine.
 

Mooseman

Moderator
Dec 4, 2011
25,649
Ottawa, ON
Locked and continued in new thread.
 
Status
Not open for further replies.

Forum Statistics

Threads
23,479
Posts
639,805
Members
18,707
Latest member
obd

Members Online