I don't have Bose after all

fadyasha

Original poster
Member
Dec 21, 2011
1,134
Well went to install a HU today and from what the guy tells me I don't have Bose! So my gmos-04 is worthless! Is it possible I screwed up on this? The answer is yes but how do I make sure ?
 

Black_tb

Member
Dec 6, 2011
817
couple ways one being you would speakers/ tweeters in the dash I'm sure there is a code in the glove box but off hand don't know what that would be and last there should be a amp some where
 

STLtrailbSS

Member
Dec 4, 2011
1,617
Amp behind rear panel passenger side. Cant you just cut the RCA's and treat the wires as a non bose harness atleast Scoche Harnesses are like that
 

fadyasha

Original poster
Member
Dec 21, 2011
1,134
Thanks guys! I could try that but first hand when tried connecting the rca's nothing in the back. My rear controls were out.

Yup no Bose what a bummer lol! I don't even know how I was so sure I had it lol
 

STLtrailbSS

Member
Dec 4, 2011
1,617
anything in the manual about adapting the harness for non bose? Or its it strictly bose don't have experience with GMOS
 

fadyasha

Original poster
Member
Dec 21, 2011
1,134
Strictly Bose! There's the gmos-01 for mine. I'm sure there's a way around it but my Ltz has so many options and I'm sure I'll screw something up.

I contacted the seller and they said I can send it back and they'll exchange it for me with what I need and refund the difference :wink:!

Unless a fellow member wants it I could sell it instead lol
 

MAY03LT

Member
Nov 18, 2011
3,422
Delmarva
fadyasha said:
Is it possible I screwed up on this? The answer is yes but how do I make sure ?

fadyasha said:
I have the TB LTZ model which makes it a bit more difficult to find a unit because of the:
1. Steering Controls
2. OEM Bose System

Well you probably already know this, but yeah, you can't blame us for this!:cool:

This is a good example of why the trim level can't be used for determining what options that you have. FWIW, my 03 LT didn't have bose or onstar, but it did have the LTZ wheels.:crazy:
 

DJones

Member
Jan 21, 2012
701
St. Petersburg, Florida
MAY03LT said:
...my 03 LT didn't have bose or onstar, but it did have the LTZ wheels.:crazy:

Bose and OnStar were optional on most trim levels, and the "LTZ" wheels only came on the SWB LTZ, TNF, EXT, and EXT TNF. AKA Ascender wheels. Maybe the dealer put them on.
 

fadyasha

Original poster
Member
Dec 21, 2011
1,134
MAY03LT said:
Well you probably already know this, but yeah, you can't blame us for this!:cool:

This is a good example of why the trim level can't be used for determining what options that you have. FWIW, my 03 LT didn't have bose or onstar, but it did have the LTZ wheels.:crazy:

Loool seriously man! U live and learn
 

MMIN

Member
Feb 26, 2012
55
Thanks guys! I could try that but first hand when tried connecting the rca's nothing in the back. My rear controls were out.

Yup no Bose what a bummer lol! I don't even know how I was so sure I had it lol
When you turn the OEM radio on it will say BOSE on the display for a second. Also you can look through the grills in on top of the dash to see if there are speakers there. Last in the glovebox look at the RPO code list - UQA should be premium audio. If you tried to use a bose interface in a nonbose vehicle you would normally get very low volume out of all of the speakers. Are you saying the front speakers seemed ok with the harness?
 

DJones

Member
Jan 21, 2012
701
St. Petersburg, Florida
MMIN said:
When you turn the OEM radio on it will say BOSE on the display for a second.

:confused: Mine doesn't. :confused:

However, it does have a white decal that is on there 24/7/366.
 

MMIN

Member
Feb 26, 2012
55
However, it does have a white decal that is on there 24/7/366.

Good point forgot that one! If it doesn't say Bose when turning on it is right on the face of the radio - bottom left of the display I believe?
 

STLtrailbSS

Member
Dec 4, 2011
1,617
Fad this only mean ones thing. Time to make your own bose system order amps ASAP! SonicElectronix.com :rotfl:
 

Boricua SS

Member
Nov 20, 2011
3,080
Ohio
MMIN said:
When you turn the OEM radio on it will say BOSE on the display for a second.

this is false for determining if you have BOSE...

my facrotry HU flashed BOSE when i bought my SS... however, no amp in the rear cargo area, no UQA RPO code, and no tweeters in the dash vents...
 

MMIN

Member
Feb 26, 2012
55
my facrotry HU flashed BOSE when i bought my SS... however, no amp in the rear cargo area, no UQA RPO code, and no tweeters in the dash vents...

Did you buy it new or used? It isn't uncommon for customers to want a 6-disc instead of the single disc and dealers will swap a bose radio into a non-bose vehicle. Program it up and you have a vehicle like yours that appears to have Bose but really doesn't. If you bought it new and know this isn't the case, than that's strange and I'm not sure how that could happen.
 

Boricua SS

Member
Nov 20, 2011
3,080
Ohio
MMIN said:
Did you buy it new or used? It isn't uncommon for customers to want a 6-disc instead of the single disc and dealers will swap a bose radio into a non-bose vehicle. Program it up and you have a vehicle like yours that appears to have Bose but really doesn't. If you bought it new and know this isn't the case, than that's strange and I'm not sure how that could happen.

i bought it slightly used.. only had 9400 miles on her... less then a year old.. so if thats the case.. someone swapped things out fast... i didnt have the 6 disc.. just a single POS! :rotfl:, so why someone would want to swap to that is beyond me...
 

MMIN

Member
Feb 26, 2012
55
i bought it slightly used.. only had 9400 miles on her... less then a year old.. so if thats the case.. someone swapped things out fast... i didnt have the 6 disc.. just a single POS! , so why someone would want to swap to that is beyond me... .

In that case chances are your truck got the raw end of the swap and you had the 6-disc. Guess you don't have the window sticker for it?
 

The_Roadie

Lifetime VIP Donor
Member
Nov 19, 2011
9,957
Portland, OR
MMIN said:
When you turn the OEM radio on it will say BOSE on the display for a second.
Fascinating. In my long time with this platform, I never heard or saw that. And it seems it's not definitive. :confused: I have an SLT with Bose and mine doesn't flash on the display. What POSSIBLE reason would GM/Delphi have to flash a LIE on the display? :mad:
 

Boricua SS

Member
Nov 20, 2011
3,080
Ohio
MMIN said:
In that case chances are your truck got the raw end of the swap and you had the 6-disc. Guess you don't have the window sticker for it?

if it did have it, then im unaware... and yes i have the sticker for it... sticker just says AM/FM Stereo, then CD Player underneath it...

oh well no biggie for me... i have since gone waaaaay aftermarket :crackup:
 

STLtrailbSS

Member
Dec 4, 2011
1,617
Boricua SS said:
if it did have it, then im unaware... and yes i have the sticker for it... sticker just says AM/FM Stereo, then CD Player underneath it...

oh well no biggie for me... i have since gone waaaaay aftermarket :crackup:

It's much easier to rip it all out then to find out if you have bose. I have gone through with that method in every vehicle I have had lol
 

Matt

Member
Dec 2, 2011
4,030
the roadie said:
Fascinating. In my long time with this platform, I never heard or saw that. And it seems it's not definitive. :confused: I have an SLT with Bose and mine doesn't flash on the display.

I have an LTZ with the 6 disc BOSE system (RQA RPO, speakers, amp) and mine doesn't do anything like that either.
 

MMIN

Member
Feb 26, 2012
55
The older radios should have Bose printed on the display, the newer ones and nav units should say it on the screen when they turn on.

View attachment 19241



if it did have it, then im unaware... and yes i have the sticker for it... sticker just says AM/FM Stereo, then CD Player underneath it...

Interesting.. I guess there is always the possibility that if they ran out of radios they would put in whatever during assembly, but being even slightly used I would guess something else happened. Anything from a dealer swap like mentioned earlier, or the truck was traded in with aftermarket equipment and the dealer put it back to an OEM radio, or the face was damaged and replaced with one that said Bose, etc.
 

Attachments

  • bose.jpg
    bose.jpg
    34 KB · Views: 3

Boricua SS

Member
Nov 20, 2011
3,080
Ohio
MMIN said:
Interesting.. I guess there is always the possibility that if they ran out of radios they would put in whatever during assembly, but being even slightly used I would guess something else happened. Anything from a dealer swap like mentioned earlier, or the truck was traded in with aftermarket equipment and the dealer put it back to an OEM radio, or the face was damaged and replaced with one that said Bose, etc.

that could be... but either way, the radio has since been long gone :crackup:.. no less then 6 months did i have all my aftermarket stuff in.. and havent looked back since..
 

Forum Statistics

Threads
23,444
Posts
639,434
Members
18,668
Latest member
Zee0719

Members Online