2007 trailblazer won't start after trying a few things

Shelby2010

New Member
Have an 07 trailblazer. The battery was draining every day. Put a new battery in, changed the alternator. Still draining. Used mutli meter and checked every fuse in the hood and back. Found that the ignition switch was drawing voltage. So we changed the ignition switch and now the car will not start, it won't even crank over. Any help on this? Note that the car started and ran before this just the battery was being drained!
 
OP
OP
Shelby2010

Shelby2010

New Member
I have moved the tooth part several times to try and get it in the correct spot I may still have not got it correct. I've looked online and YouTube for instructions. Is there a set spot you know is correct?
 
OP
OP
Shelby2010

Shelby2010

New Member
The dash lights up like normal just won't crank. No security light or anything. The check engine light stays on but it was on before so I don't know if it means anything.
 
OP
OP
Shelby2010

Shelby2010

New Member
So we found that while I was installing the ignition switch I must have pulled a wire loose from a connector under the steering wheel and we wired it back together and the car cranks now, pretty sure it needs a new battery now. However something weird the rear windshield wiper comes on while the switch is off now, don't know why. But thanks for the help!
 

Members online

Forum statistics

Threads
18,861
Messages
571,203
Members
11,530
Latest member
sliptap

Members online

Top Bottom