Product Review: Eonon GA2189; Android 10 OS w/10" Screen

Blckshdw

Moderator
Figured I'd make a thread to document my experience with this unit, since I didn't do so with the last one. This is a 2021 model Android HU from Eonon, off Amazon. If you read the full description, at least at the time I bought it, you could choose 3 of 4 accessories to receive for free.
Clip_2.jpg

The unit comes with the removable 10" screen attached. To remove it, there are 2 spring loaded slide clips on the back of the screen, that you pull outwards with your finger tips, and then the screen slides up and off. The ribbon cable has a cover that's held in by screws. I was hoping for a tool-less removal design, but the cover can be left off. With a slight pinch of the ribbon cable, it detaches easily.

20210725_090253.jpg


On the main unit, you can see the bracket the screen slides down onto. There are a number of teeth along the outside of the bracket, that the screen's latches grab onto. These also provide vertical placement adjustment which was an unexpected bonus. I was able to move the screen up a bit, so it's not right over the HVAC controls. This model has a swivel mount, so not only does it tilt from left/right and up/down, it also rotates. There's a limit restrictor at about the 2 o'clock position to keep you from damaging the wiring harness to the screen.

20210725_090602.jpg
20210725_111125.jpg

On the top of the unit is a wiring harness map, and it's oriented so if you tip the unit down in order the read it, it lines up with the plugs on the rear if you tip the unit down further (making it upside down) without having to flip the thing around. Very useful if you already have some of the harnesses connected, and not a lot of slack to work with. I wasn't able to use my previous GPS antenna, I thought there was an industry standard, but apparently not. I was able to use my previous wifi antenna, which is a short stubby version, compared to the long wired, sticky tape one that came with the unit.

20210725_090625.jpg


After getting everything hooked up and powered on, this is the stock screen layout. If you tap and hold any of the shortcuts, an Android icon shows on the left side of the screen. Dragging the shortcut to it, deletes it from the home screen. There is also a second page, where shortcuts can be moved/added to.

20210725_091130.jpg


After setting up the Bluetooth and wifi connections, I did a quick internet speed test. Decent for the radio, although it doesn't really need that much. Tested out Youtube TV, and it streamed smoothly.

20210725_091944.jpg


Setting up the steering wheel control buttons wasn't too bad. Clear the existing settings, tap the icon on screen you wish the program, and it starts to blink. Press the steering wheel button, and when it goes solid, you know it's done. Only drawback I saw, was the inability to program short and long press assignments, given how many options they have available. A couple of these, I'm not sure what they mean, the details aren't in the documentation.

20210725_091442.jpg


Digging in a bit deeper, I was able to pair my existing OBDII adapter. I like the stubby versions, the longer ones I always bump with my legs. I have a BT battery monitor, which I had some difficulty trying to pair. I think the problem is with the battery monitor, as I wasn't able to pair it with my previous Android HU either. At least this unit actually sees it, but when you try to pair, it gives you the code to input on the external device, instead of asking for the incoming code like with the OBDII.

20210725_092352.jpg
20210725_092124.jpg


The navigation shortcut defaults to Google Maps, but in the nav specific settings, you can reassign it. I prefer Waze, so that was a quick change after downloading all my preferred apps.

20210725_100945.jpg20210725_100953.jpg20210725_101001.jpg20210725_101009.jpg

Torque comes pre-installed, so that worked just fine. Downloaded CarGauge Pro, but that didn't seem to work for me. Since it hasn't been updated in so long, you do get a warning message, and going past that, I wasn't able to read from the truck side after connecting to the adapter.

20210725_102323.jpg20210725_102610.jpg


As mentioned by @Mooseman in another thread, the dashcam app is terrible. It doesn't come pre-installed, so you have to use the file manager to search for the APK in the camera once connected, and install it manually. All it did was repeatedly crash on me with an error message. Luckily the dashcam I had previously works just fine, following the same install procedure. So my recommendation is to get a good quality USB dashcam and run with that.

There is an AV input in addition to the backup camera input, so I plugged my secondary rear cam into that. Unlike my previous unit, when selecting to view this input, it turns off the BT music stream. I normally use this camera when the cargo area is loaded up and I can't see through the back window in the rear view mirror. Not sure if there is a workaround for that. When using the normal backup cam input, the music does reduce some, there's a setting to adjust that under Reverse Volume Suppression. It defaults to weak.

20210725_091321.jpg

That's about as far as I've gotten so far this weekend. The steering wheel button connector is going to get redone, as the solder joints don't look that great, and I think that contributed to a resistance issue with the first unit. With this one, even after programming, the buttons don't activate the proper functions. So a new 3.5mm jack will get put in to try and eliminate it as a possible cause.

Let me know if anyone has any questions, I put my screen recorder software on it, so I can record how things look/work if there's anything specific someone wants to see. :thumbsup:
 

Mooseman

Moderator
Test the mic in the unit's face to make calls. Mine was terrible and would have needed a separate one plugged in and mounted elsewhere. People couldn't hear me, sounded muffled.

How quick is the boot up? Mine was painfully slow, like 20-30 seconds.
 
OP
Blckshdw

Blckshdw

Moderator
I had my previous external mic that I routed up into the overhead console, so I plugged that in. I'll have to test that out, probably just leave myself a voicemail at work with the windows up, vs with the windows down to see how the road noise is.

Initial boot up time was painful for me as well. About 35 seconds. Fortunately I found the Sleep Mode option in the common settings. You have to turn that on, and then do a manual reboot of the unit with the power button. Now it's up on the home screen in about 2 or 3 seconds after the key goes on, like I'm accustomed to.

20210725_091256.jpg
 

Mektek

Well-Known Member
How did you get the steering wheel controls to work?
My radio needs to measure a specific resistance and since all the buttons are on one wire I can't make it work.
 
OP
Blckshdw

Blckshdw

Moderator
I bought a PAC SWI-CP5 adapter several HU's ago when I did the DIC cluster/steering wheel swap. It reads whatever the buttons are putting out, and outputs the variable resistances. They have a couple of lower priced options, but this one allowed for pre-programming via laptop.

1627490796122.png

I'm actually having an issue with mine ATM. The buttons worked fine for a day or so, and then started giving me the incorrect commands when pressed. After resetting them, I haven't been able to reprogram them. In troubleshooting so far, I've narrowed it down to the HU wiring harness, but I've got more testing to do.
 

Mooseman

Moderator
OP
Blckshdw

Blckshdw

Moderator
You don't need an interface to make them work.
Steering controls on Android HU

:undecided: Hopefully I can try that, and it works. Although it makes me wonder why the adapter worked with the previous Android HU, and with this one briefly. Would be nice to get some of the clutter out from inside my dash. Kinda crowded in there. :yes: I wondered why there were 2 ground wires in different harnesses, but that thread makes sense of it for me.
 

TollKeeper

Gold Supporter
Can you tell me if it has Aux Video Out? for a second screen.
 
OP
Blckshdw

Blckshdw

Moderator
Tried the @Mooseman method for the steering wheel controls and it works perfectly now. :2thumbsup: Pulled the PAC module out, was nice to get rid of 1 of the many wire bundles in there. There are 2 ground connections from the HU, but they aren't distinctly labeled. I chose one, connected to the pink wire. Connected Key1 to the green wire. Hooked everything back up and the buttons programmed as expected.

Can you tell me if it has Aux Video Out? for a second screen.
It does, there's a USB box with a pair of RCA video outs on it. I haven't used it though.

20210728_204527.jpg
 
OP
Blckshdw

Blckshdw

Moderator
Update time. Don't think I'll be keeping this unit, it's got too many little problems to be worth it to me. After a few days, I started having intermittent problems with my 5 channel amp getting turned on. Since removing the steering wheel control adapter, I had an available connection to the RAP circuit, so moved the amp turn on wire to that as a bypass. Contacted tech support, and they suggested a software update. Didn't help.

Could have lived with that, but the fast boot feature is also sporadic. Turning the vehicle off, and then the key back on, it boots up instantly. Sometimes I can come back 15 minutes later, and it still boots up quickly. But there are also times it doesn't, and takes the full reboot time which is annoying. Anytime I stop for more than an hour, and it's always the full boot up time. If that was a solo problem, might have been able to deal with that, but the Bluetooth music selection doesn't auto start when it was the last thing open. Radio does, the AV in connection does, and the music player that reads from the SD card does as well, just not the one that I actually use. :confused: Meh, OK, just a quick tap on the home screen so minor inconvenience.

When headed to my sister's place, she called me. The call quality was pretty spotty, and the audio broke up frequently. I figured it was on her end with a bad connection. This morning during my commute, I called my office phone to leave a message for a sound quality check. Got to my desk to listen to it, got the same choppy audio with frequent cut outs, making the 15 second message worthless. Granted I rarely make/take calls while in the truck, but when I do they're usually important.

So with this combination of little issues, it's a deal breaker overall. 👎
 

Mooseman

Moderator
Yeah, the Eonon name is mud with me too and I had many more issues than you. I tried for too long to make it work and couldn't return it. I've got older units from other brands that worked better than this one.
 

Online statistics

Members online
9
Guests online
200
Total visitors
209

Forum statistics

Threads
21,557
Messages
613,917
Members
15,616
Latest member
Rapscallion

Secure Browsing

Top Bottom