Leaking gas , gas gauge fluctuations

nbenjamin

Well-Known Member
So still got the not ready for emissions cause of mass leak.
I now know the leak is from the pump. There is gas leaking down the tank when engine running. Will replace pump as soon as this cold weather is gone.
I noticed since battery change gas gauge all over the place
Would tank not keeping pressure cause gauge to fluctuate? I did change all gauges years ago. And I did change sending unit years ago too.
Thanks
 

Blckshdw

Moderator
When you say the gauge is all over the place, does it remain between the full and empty marks? And zero out at the empty mark when the ignition is turned off? If so, I'd be more suspicious of the sender again, rather than the stepper motor.
 
OP
OP
N

nbenjamin

Well-Known Member
When you say the gauge is all over the place, does it remain between the full and empty marks? And zero out at the empty mark when the ignition is turned off? If so, I'd be more suspicious of the sender again, rather than the stepper motor.
I believe the stepper motor is fine. When I start it goes to 1/4 maybe then after a while empty then maybe 1/2 then after driving for a bit back to 0. I just find it hard to believe everything is failing again since battery change. Then again nothing really surprises me with these gm vehicles anymore
My question was wondering if it has any relation to the tank losing pressure. I have major gas smell and like I said dripping of top of tank when engine running
 

Blckshdw

Moderator
Since the level sender is just a float switch, I wouldn't think pressure would affect it at all. Since you'll have the tank dropped and pump removed, you can test it, and make sure the resistance it's putting out is smooth and consistent like it should be. If it is, then maybe you have a damaged wire or connector somewhere?
 

HARDTRAILZ

Moderator
Sure sounds like the typical failure of the level sender. Gauge bounces around until it dies and stays on zero. I would highly doubt pressure or stepper having anything to do with it.
 

Maverick6587

Well-Known Member
Where "exactly" is the fuel leak coming from? From the front of the tank (near driver's seat), the rear of the tank, or the outside (near the frame)? If you can't tell. While you're waiting for the warmer weather, you could by a borescope off from Amazon/Ebay. They're usually about $10. From experience, I would spend the extra (any amount) to get the 1080p version of the scope. It's needed for dark areas when looking for detail. The 720p is really grainy. I bought 3 720p versions and they were all just as bad as the next.

I agree with HARDTRAILZ and Blckshdw, that it sounds like the level sender is bad. I've seen them at a 1/4 tank and then as your driving go right to full or right to empty for the remainder of the ride, fuel sending unit still fully functional.
 
OP
OP
N

nbenjamin

Well-Known Member
Thanks for all the replies guys
I think I have 2 issues
The tank must be leaking from the pump. Judging by the pics I have from 2011 when I changed the sending unit the fittings on the pump were rusted then and it’s been since 2011 and 100,100km since I did the sending unit.
The tank had stain marks around the area of the pump on the passenger side
Just sucks that everything all at the same time.
Just the battery , tie rod , cam shaft solenoid, I do one thing the next day something else.
I will change out the complete pump unit this time.
Was looking on rock auto. I don’t want to ever drop the tank again. Suggestions on brand that will last. The OEM sending unit only lasted 100 000 km
 

Maverick6587

Well-Known Member
I would stick with OEM, but which make did you use, ACDelco, BOSCH, or Delphi? I would also hang on to the pump you are about to remove and just get the rust off of the pump fuel lines and replace the fuel level sending unit at some point on that one and then you have a spare pump to use or sell.

If you don't care about the fuel level, you could just drop the tank and clean off the fuel sending and return lines of rust. Then make lift it enough that you can reattach everything and check for fuel leaks again, while it's down enough to visually inspect for leaks.

While you're under your vehicle you might as well take care of the ground wires associated with the fuel pump as well, if you're feeling up to it. There are two easy to get to grounds on the outside of the frame on the driver's side (Frame Grounds attachment). One is near the driver's door and the other is near the passenger's door. If you're feeling like taking over the world that day, there are four other grounds on the driver's side of the engine (Engine Grounds attachment). Only one of those 4 grounds on the engine is a parts of that fuel pump circuit (I think it's the top right, looking at the screenshot), but they're all inches apart from each other.
 

Attachments

Mooseman

Moderator
Bosch makes them for ACDelco. Delphi has had suspect quality lately with another member having issues with them.
 
OP
OP
N

nbenjamin

Well-Known Member
I think if my notes are correct is was OEM sending unit. I agree about keeping the pump and having it as a spare except it will depend on how bad the leak is from the pump lines how badly rusted and rotted out. Also just replacing the old sending unit won’t do me much good because if the lines are that bad I don’t think patching them with JB or other is worth it as a fix when I think of the work involved in dropping the tank , especially I’m now 10 years older lol dam aging .
Was considering this https://www.rockauto.com/en/parts/bosch,67508,fuel+pump+&+housing+assembly
Suggestions
 
Last edited:

Maverick6587

Well-Known Member
Bosch is a good brand and that's a great price for it too. I would definitely buy that pump. I'd rather have it on hand than not when you pull the tank down.

If you're concerned that the leak is from the top of the fuel sending unit's hard metal lines, I would go to a junk yard and also get the plastic lines that attach to it. Each (two) of them disconnect at the front of the fuel tank. It's usually about a dollar/ft at a "you pull it" yard. I would also be concerned that the rust broke/broke down the rubber seals and/or the plastic clips, especially since it is leaking fuel. Depending on your experience with those fuel line clips, it could be an easy grab or it could take you 30 minutes.

You'll need either two small screw drivers and/or a few small pick tools. I'm sure there's a specific tool that makes releasing those clips a breeze.... I wish I would have looked for it before I pulled my tank. I thought it would be easy, but that was what took the most time in removing the tank, was pulling all of those plastic clips.

I just broke the small clips on mine. A pack of 6 clips is only about $5 at most parts stores, locally.
The large evap clips are $15-20 for 3 of them and they are plastic, so be careful with those evap clips. Or just grab a bunch of those clips from the junk yard as well.

It doesn't sound like you have any bad ground wire, I just mentioned that because you are going to be able to easily see them on the frame as you go under your vehicle. Because if your metal fuel lines are rusted that bad, then I assume that the frame or at least the ground bolts are rusted just as bad. The two grounds on the frame were rusted/corroded. I lost my 5v computer reference voltage at one of those grounds. I think it was the ground wire near the passenger's door that was for the 5v reference for the evap system.

Cleaning the ground wires was just a preventative maintenance suggestion is all. One if not two of the grounds could stop your fuel pump from functioning. I attached the ground distribution so you could see what all could go wrong if that ground is lost to rust/corrosion.

Sorry for the long post. I've just been there twice in a two-three week period and learned so much, lol.

EDIT: After/if you clean those ground wires and the frame where they connect to. Make sure that you also spray them with some battery terminal sealer as well. I used dielectric grease and that only lasted a few weeks. I had to clean them all over again.

I'm not sure if painting them once they are cleaned and reattached is a good idea or not. It was a thought I had, but didn't want to chance having to clear paint and corrosion anytime soon.
 

Attachments

Last edited:

Mooseman

Moderator
I had the line rust out on my Saab. When I went to pull the plastic connector, a plastic spacer for the seals had rusted on solid and was destroyed. Although I was able to make another one using a small brass ring, you can get replacement connectors and unions from Dorman. All my clips had also broken but the evap connectors were fine.

When they rust out like this, they can't be salvaged or repaired.
 
OP
OP
N

nbenjamin

Well-Known Member
Opinions? I read that some had issues with Bosch

About the pump lines rusted when you guys say the ends you mean the ends that the connector is attached to ? Are they not crimped on ?
 

Maverick6587

Well-Known Member
Mooseman stated that a few people had issues with the Delphi fuel pump. I put a Delphi pump on my 97x and it's been fine for about 3 months so far. You're never going to find a perfect fuel pump. Someone will have had an issue with any make/model. Just stick with either ACDelco, Bosch, or Delphi (maybe not Delphi for the fuel pump) when putting parts on a Trailblazer, Envoy, Rainier, 9-7x, or Bravada etc..

The pump lines are not crimped on. They are held on by plastic clips as seen in the attachment. I don't know if the standard fuel line lock tool works on the clip connectors. I didn't even think about it as I was working on it. You can get a set of plastic fuel line tools at Harbor Freight for about $6 though. Maybe someone else could suggest a better tool or knows if the standard fuel line tools work on these clips.

All I know is that if I had a tool to get those clips off the lines, other than screw drivers and picks, I could have had that tank off in about 20 minutes vs the hour+ that it took.
 

Attachments

Last edited:
OP
OP
N

nbenjamin

Well-Known Member
you're concerned that the leak is from the top of the fuel sending unit's hard metal lines, I would go to a junk yard and also get the plastic lines that attach to it
Sorry I think I miss understood what you were saying I should be ok with the clips. I thought u meant change plastic lines ends with the clips
 

Maverick6587

Well-Known Member
Sorry I think I miss understood what you were saying I should be ok with the clips. I thought u meant change plastic lines ends with the clips
No worries. The fuel line on the right without the white clip at the end of it, I would disconnect that line further away from the tank. It's kind of hidden back above the fuel tank. There is another plastic connector clip about a foot away from the tank. I would disconnect that line there. Much easier to reach and see the clip!
 

Members online

Forum statistics

Threads
18,869
Messages
571,289
Members
11,536
Latest member
Train4mation

Members online

Latest posts

Top Bottom