Finally swapped engine, no start now...

Gibby

Original poster
Member
Jan 15, 2012
34
Only took about 10 months but I finished my engine swap. Had some issues along the way but I put in an '05 Engine with 50K miles on it. We rolled it out of the garage around midnight Saturday and attempted to start it. It just cranks. We verified that it is getting fuel so we started checking fuses. We finally found that the number 32 fuse under the hood was blown, it is one of the larger fuses and is marked for Trailer. I am not 100% sure this would stop it from starting so we put in another fuse and the lights and dash went crazy and it blew again. So I am hoping this is the issue, I just need to figure out where the wiring is and goes for this fuse. Any ideas?


Edit: Forgot to add, I hooked up a computer and there are no codes.
 

Gibby

Original poster
Member
Jan 15, 2012
34
So it looks like my engine had a 58x reluctor, based on year from this link I thought I had a 24x, never even thought about checking when I had both engines out. I really do not want to pull it to change them, so I have 2 options.

1. Try to get my neighbor, who i just found out is a GM guy and runs a mechanic class at a school about an hour away, to use it as a project for his class... :wink:
2. Find a away to make it work without pulling the engine, the Lingenfelter converter looks like it only goes 24x-58x not 58x-24x, or maybe changing to an older ECM?
 

6716

Member
Jul 24, 2012
822
I hate it when that happens! :eek:

Aw, shoot, pull the engine. If it's worth doing, it's worth doing right, right?

Plus, it'll go faster this time.:biggrin:
 

GCTB1289

Member
Mar 19, 2012
699
Gibby said:
Bad thing is, after I had the engine in, I sold my engine lift.... :redface:

damn that sounds like a problem. well what kind of turn around could they have if you have your neighbors class do it
 

Gibby

Original poster
Member
Jan 15, 2012
34
gcacace1289 said:
damn that sounds like a problem. well what kind of turn around could they have if you have your neighbors class do it

Haven't heard back from him yet, it only took me 10 months the first time lol. My dad and I can probably have it ready to pull in one long Saturday now though.
 

Gibby

Original poster
Member
Jan 15, 2012
34
So it looks like LPE will not be releasing the TRG-002R, I have tried multiple times to get them to send me one and even pay for one without a warranty. Does anyone else know of someone or somewhere I can get ahold of one? Wife is hounding me to get it out of the garage and really don't want to do another engine swap. Thanks :smile:
 

Forum Statistics

Threads
23,330
Posts
637,987
Members
18,532
Latest member
timmerk

Members Online