AC Vents work on and off

dre2142

Original poster
Member
Aug 11, 2012
6
Hey all-

Today my front vents will stop blowing air, then blow air again, then turn off again. This happens no matter if its on the AC setting or non AC.

When this is happening the rear vents are constantly blowing AC air...

This is on a 2006 Trailblazer....any ideas?
 

The_Roadie

Lifetime VIP Donor
Member
Nov 19, 2011
9,957
Portland, OR
Welcome!

Do you mean the BLOWER cuts out and you have no airflow in the front from ANY of the outlets (dash, feet, windshield) or the dash vents shot off and divert the airflow elsewhere?

Do you hear the blower motor cut in and out?

Do you have the manual HVAC controls or the digital/automatic ones?

Have you recently discharged or disconnected the battery?

EDIT: Without your vehicle profile being filled out, we have to ask more questions. Do you have an EXT?
 

dre2142

Original poster
Member
Aug 11, 2012
6
Hey Roadie-

Ill update the profile.

I have the 2006 LS with the digital console....knobs to control each side. With the center rear vents in the center console.

When I lose air flow I believe the blower motor is cutting out- im not getting any air from ANY of the front vents. Sometimes there will be a slight flow of air, but most times its nothing at all. It will stay off for 1 minute, and then come back on for 4, and then off for 5, and then on for 10. Its intermittent.

The rear air coming out of the center console continues to blow cold air throughout.

The battery was replaced about 1000 miles ago....

Could this be a blower motor control module/resistor?
 

The_Roadie

Lifetime VIP Donor
Member
Nov 19, 2011
9,957
Portland, OR
dre2142 said:
Could this be a blower motor control module/resistor?
You called it. In the digital system it's a continuous variable speed control, like a dimmer. More expensive, of course, than the resistor pack that also fails a lot.

In your case it could also be overheated/oxidized wiring harness connector pins, but it's worth getting down there under the glove box and pull out the module and inspect the wiring.

For more reading:
http://gmtnation.com/f23/blower-motor-resistor-help-2053/
http://gmtnation.com/f23/possible-control-module-problem-blower-motor-wont-turn-off-1440/
 

dre2142

Original poster
Member
Aug 11, 2012
6
Thanks Roadie- Is this a dealer only part or can I get it online somewhere? There are a lot of threads on this but so much information its overload.

I think its GM Part 19260762? I also see GM part 89018778.
 

The_Roadie

Lifetime VIP Donor
Member
Nov 19, 2011
9,957
Portland, OR
dre2142 said:
There are a lot of threads on this but so much information its overload.
There are a lot of new members with questions and answering each one is a different kind of overload. :wink:

Please read the threads I linked. It's available in the aftermarket for a LOT less than the dealers. Friends don't let friends pay full retail at dealers. :wootwoot:
 

Denali n DOO

Member
May 22, 2012
5,596
dre2142 said:
Thanks Roadie- Is this a dealer only part or can I get it online somewhere? There are a lot of threads on this but so much information its overload.

I think its GM Part 19260762? I also see GM part 89018778.

Heres the one I used, its an updated part from the stock one. I bought mine at the dealer and installed myself, with Roadie's help of course.
 

Attachments

  • DSC02290.jpg
    DSC02290.jpg
    87 KB · Views: 10
  • DSC02291.jpg
    DSC02291.jpg
    63.7 KB · Views: 9
  • DSC02292.jpg
    DSC02292.jpg
    68.4 KB · Views: 9

dre2142

Original poster
Member
Aug 11, 2012
6
Denali n DOO said:
Heres the one I used, its an updated part from the stock one. I bought mine at the dealer and installed myself, with Roadie's help of course.

I guess Ill order part 15-81728 (2 day shipping total of 66 bucks) and see how it goes.
 

Denali n DOO

Member
May 22, 2012
5,596
dre2142 said:
I guess Ill order part 15-81728 (2 day shipping total of 66 bucks) and see how it goes.

I never saw that part number, I know the heat sink on my new one was a much better design than the original. I wonder how the one you ordered differs? Post a pic when you get it if you can.
 

dre2142

Original poster
Member
Aug 11, 2012
6
Denali n DOO said:
I never saw that part number, I know the heat sink on my new one was a much better design than the original. I wonder how the one you ordered differs? Post a pic when you get it if you can.
im actually picking one up from NAPA in about an hour- looks like the one you got with the heat sink. Costs 100 but ill pay a little more so i dont have to wait for it to ship.
 

wedge1

Member
Apr 29, 2013
45
I have the same symptoms on my 2005 with auto HVAC. Someone said that the part is located under the glove compartment. May I have a little more information on this location please. wedge
 

Forum Statistics

Threads
23,236
Posts
637,132
Members
18,404
Latest member
Zoie

Members Online

No members online now.