Yokohama Geolander A/T-S

TBGal

Original poster
Member
Sep 14, 2012
30
This are the tires that the dealership put on my truck new before they listed it for sale and I bought it.

They aren't necessarily the tires that I would have chosen, but I'll say this for them:

on wet pavement, they GRIP.

Anybody else had these tires? I am hoping they last a while.

I am gonna do my part in helping them last - regular tire rotations, I check my tire pressure weekly, etc.
 

MacMan

Member
Mar 3, 2012
194
They were the 3rd set of tires I put on my TB, and I liked them. No issues at all, and they DID grip well.

That being said, the latest tires to go after the Geolanders are General Grabbers.......better tire, IMO.
 

TBGal

Original poster
Member
Sep 14, 2012
30
Cool. Good to hear, MacMan.

Well, I checked my tire pressure again today, as I have been doing once per week since I got the vehicle about a month ago...and I am consistently losing about 2 psi/week in the rear tires. They get 2 psi low, I fill back up to 35, and I am back 2 psi down again a week later. So, I am thinking maybe leaky valve stems.
 

C-ya

Member
Aug 24, 2012
1,098
If you have a valve stem tool, try tightening the stems. Any parts house will sell it if you don't have one.

I have General Grabbers on mine, too. The PO just had them put on before they traded it in. So far, so good. Only wet weather to try the grip so far, but I like what I have felt. This winter should tell the tale, tho.
 

TBGal

Original poster
Member
Sep 14, 2012
30
C-ya said:
If you have a valve stem tool, try tightening the stems. Any parts house will sell it if you don't have one.

This I can do! I'll buy that tool this weekend.
 

Forum Statistics

Threads
23,225
Posts
637,042
Members
18,380
Latest member
SpencerT

Members Online

No members online now.