Wierd Application of ABS when turning and braking

CaptainXL

Original poster
Member
Dec 4, 2011
2,445
I have noticed a weird phenomenon with my '05 XL. Basically what happens is that when I am maneuvering in a parking lot at slow speed and I turn the wheel while braking I notice the ABS kick in for a second or so. Very strange. The only thing I can think of is that the ABS sensor wire is loosing connection.
 

Sparky

Member
Dec 4, 2011
12,927
Mine did that for a while. It was because I had a bad hub bearing that was allowing enough play for the sensor to loose track of the wheel speed on occasion, making it think the wheel locked up and triggering the ABS.

If your bearing is fine then it is possibly just a mucked up sensor. Check the plug for any grime, maybe remove the sensor and clean it.
 

CaptainXL

Original poster
Member
Dec 4, 2011
2,445
Sparky said:
Mine did that for a while. It was because I had a bad hub bearing that was allowing enough play for the sensor to loose track of the wheel speed on occasion, making it think the wheel locked up and triggering the ABS.

If your bearing is fine then it is possibly just a mucked up sensor. Check the plug for any grime, maybe remove the sensor and clean it.

I just jacked up the front of the truck and spun both tires and they won't spin at all...very stiff. I guess this means the bearings are going? I didn't notice any play when grabbing the top and bottom of the tire.
 

SBUBandit

Member
Dec 5, 2011
597
CaptainXL said:
I just jacked up the front of the truck and spun both tires and they won't spin at all...very stiff. I guess this means the bearings are going? I didn't notice any play when grabbing the top and bottom of the tire.

My old grand am used to do the same thing and it was the wheel speed sensor. As for the wheels being stiff to spin, I just had to replace the bearings on the TB, and I knew they were going from the sound. The truck sounded like it had mud tires on it anytime i went over 35. Not a bad job overall though.
 

jrSS

Member
Dec 4, 2011
3,950
CaptainXL said:
I just jacked up the front of the truck and spun both tires and they won't spin at all...very stiff. I guess this means the bearings are going? I didn't notice any play when grabbing the top and bottom of the tire.

Well at least u know u have good ball joints. Lol
 

RayVoy

Member
Nov 20, 2011
939
CaptainXL said:
I just jacked up the front of the truck and spun both tires and they won't spin at all...very stiff. .
It may also mean, that you have a brake problem, the pads may not be releasing.
 

gmcman

Member
Dec 12, 2011
4,656
My first guess would be dragging brakes as well, but both wheels? Hmmm......is the front diff engaged?
 

CaptainXL

Original poster
Member
Dec 4, 2011
2,445
gmcman said:
My first guess would be dragging brakes as well, but both wheels? Hmmm......is the front diff engaged?

Nope. I also removed the drivers side caliper and its hard to turn unless I rotate it with both hands. Feels like trying to rotate a much larger mass
 

Forum Statistics

Threads
23,328
Posts
637,950
Members
18,531
Latest member
jvest

Members Online