Whats with the lighting in these trucks???

Denali n DOO

Original poster
Member
May 22, 2012
5,596
Here's my lighting experience so far with this Envoy, very strange behavior!

-sunroof button back light never has worked. I noticed in 06Envoy's truck the other week that his worked.:frown:
-rear defrost button back light went out (auto climate control):mad:
-front defrost button back light went out (auto climate control):hissyfit:
-blew a driver side fog light and replaced.:yes:
-steering wheel information button back light went out.:frown:
-Front defrost button back light came back on.:biggrin:
-passenger side low beam went out.:frown:
-Steering wheel information button back light came back on.:biggrin:
-volt meter back light went out.:confused:
-passenger side low beam came back on and hasn't gone out again since (that was at Christmas):crazy:
-passenger side fog light out but haven't changed it yet, lol, in case it comes back on.:rotfl:

That's some CRAZY shit going on :crazy:

So to add to this, my friends 06 Sierra had all the steering wheel button lights blow so we changed them all. He took his truck to future shop to get his new clarion hu installed, when he got it back a few of the HVAC back lights and buttons were out. Then he took it to a independent stereo store to get a amp and subs installed, when he got it back pretty much the rest of the HVAC back lights and buttons were out, only light he has now is the back light near the driver temp control knob. Weird eh? ( not to mention the independent shop broke most of the panel clips they removed, based on GM dealer pricing to replace the panels that's $1582 in damage they did to his truck),

Back to the lighting issue, why do the lights go out and sometimes come back on, whats the deal?

Anybody have a pic of what back lights are on the headlight control panel? I prob have some of those out too...
 

Jkust

Member
Dec 4, 2011
946
Interesting, I just haven't had those issues with any of my 2 current or 1 past 360's. I did have some of the steering wheel lights go out on my GM minivan at about 140,000 miles.
 

Blckshdw

Moderator
Nov 20, 2011
10,694
Tampa Bay Area, FL
:eek: Damn dude, that's some pretty bad luck with your module lights. You sure you weren't browsing the LED mod thread on your phone, where your truck could see it? Could be giving you some subtle hints! :rotfl:
 
  • Like
Reactions: Redbeard

Denali n DOO

Original poster
Member
May 22, 2012
5,596
Blckshdw said:
:eek: Damn dude, that's some pretty bad luck with your module lights. You sure you weren't browsing the LED mod thread on your phone, where your truck could see it? Could be giving you some subtle hints! :rotfl:

Lol, I do look at your LED Thread quite a bit :thumbsup: just seems really weird that this is going on especially the headlight coming back to life 3 days later...
 

Blckshdw

Moderator
Nov 20, 2011
10,694
Tampa Bay Area, FL
With the lights that went out, but came back, I would guess broken solder joints. Those would be really easy fixes if you own a soldering iron and 2 working hands with opposable thumbs. Of course, if you're gonna take all those things apart... Well, you know my opinions on that. :wink:
 

Mark20

Member
Dec 6, 2011
1,630
I've had a number of lights come and both in and out of vehicles. My guess is the bulb filament is opening and managing through vibration or whatever to reconnect thus completing the circuit.

Eventually it just gives up the ghost completely.
 

mrphoenix80

Member
Jan 1, 2013
251
Mark20 said:
My guess is the bulb filament is opening and managing through vibration or whatever to reconnect thus completing the circuit.Eventually it just gives up the ghost completely.

I have seen it happen. You get a little arc inside the bulb and the light comes back on. Because the filament "welded" back together. It rarely holds for long. It could also be a loose solder joint.
I think you better get in there and fix it. You will be happy with your new LEDs!:2thumbsup:
 
  • Like
Reactions: Redbeard

WarGawd

Member
Sep 2, 2012
468
Denali n DOO said:
Lol, I do look at your LED Thread quite a bit :thumbsup: just seems really weird that this is going on especially the headlight coming back to life 3 days later...

Just another data point - my passenger low beam quit working on me one night. I was ok with it because I had gone with a slightly cheaper bulb, and already had the Philips Crystal Vision to try next. Next day it started working again, and has never been out since - probably 2 or 3 months now. I'd forgotten about it till I saw this thread.
 

Shdwdrgn

Member
Dec 4, 2011
568
I have a bunch of detail pics I've taken as I have upgraded to LEDs in my dash. I'll be adding more pics later to my album, but I've uploaded some shots of the headlight control switch.

12297-detail-leds-including-double-bulb-give-even-lighting-across-switch.jpg
 

Sparky

Member
Dec 4, 2011
12,927
Heh, that sounds like a trip. My first car (93 taurus) had dancing dash backlights (or front lights I think actually). Never knew which side of the cluster was going to be dark, so I carried an aux light in case both went dark at the same time lol. My Trailblazer's passenger slider light went dark a long time ago, and the little green lights on indicator on the headlight switch is usually dead also, although tapping it or hitting a bump will sometimes light it back up for a short while.

Anyway, maybe you should rip yours apart and do LED conversions. I was going to do that to mine but I don't want to go through the effort :tongue: (I still haven't finished my headlight retrofit I started 2 years ago...:redface:)
 

Denali n DOO

Original poster
Member
May 22, 2012
5,596
Shdwdrgn said:
I have a bunch of detail pics I've taken as I have upgraded to LEDs in my dash. I'll be adding more pics later to my album, but I've uploaded some shots of the headlight control switch.

12297-detail-leds-including-double-bulb-give-even-lighting-across-switch.jpg

I guess my headlight switch panel is okay then, I wasn't sure if that dimmer knob was lit up at the end or not.
 

Blckshdw

Moderator
Nov 20, 2011
10,694
Tampa Bay Area, FL
Denali n DOO said:
... I wasn't sure if that dimmer knob was lit up at the end or not.

Yeah, some do and some don't. I was disappointed to see mine was one of the many that don't, when I opened it up.
 

Shdwdrgn

Member
Dec 4, 2011
568
Blckshdw said:
Yeah, some do and some don't. I was disappointed to see mine was one of the many that don't, when I opened it up.

Really? I didn't even see a way possible to add lighting to mine. I wonder if there was a certain year they added the feature, and if its possible to fit the whole control into older trucks? I guess I should have gotten some measurements while I had it apart to see if I could find a pot with a lighted handle to replace the stock unit.
 

mrphoenix80

Member
Jan 1, 2013
251
The end of the dimmer stalk does not light up in my 06 but it does have a symbol above it that does(sort of). Look at my pics in the LED MOD thread you can see it there.

Shdwdrgn : Does your dimmer push in and lock? From the pics in your album it does not look like it. My 06 does so it looks like a button. So when you push it, it pops out to a knob to adjust then push it back in.
 

Blckshdw

Moderator
Nov 20, 2011
10,694
Tampa Bay Area, FL
Shdwdrgn said:
Really? I didn't even see a way possible to add lighting to mine. I wonder if there was a certain year they added the feature, and if its possible to fit the whole control into older trucks? I guess I should have gotten some measurements while I had it apart to see if I could find a pot with a lighted handle to replace the stock unit.

I wish I knew what year/trim models got the different module, cuz I'd surely try to track one down.

Even if it wasn't to replace the whole module, just to get the different knob, it would be relatively easy to drill some mounting holes and run some jumper wires to that spot. :yes:
 

Denali n DOO

Original poster
Member
May 22, 2012
5,596
Here's what was out when I started this thread,

-sunroof button back light never has worked. I noticed in 06Envoy's truck the other week that his worked.
-rear defrost button back light went out (auto climate control)
-front defrost button back light went out (auto climate control)
-blew a driver side fog light and replaced.
-steering wheel information button back light went out.
-Front defrost button back light came back on.
-passenger side low beam went out.
-Steering wheel information button back light came back on.
-volt meter back light went out.
-passenger side low beam came back on and hasn't gone out again since (that was at Christmas)
-passenger side fog light out but haven't changed it yet, lol, in case it comes back on.


And now since I changed the passenger fog light bulb I can add to the list of burned out bulbs,

-lost the backlight/needle on the oil pressure gauge.
-lost steering wheel info button again, well just the lower light in that switch this time.

And since the dealer checked my DDM module as per the recall (the new one is there waiting for me to come in)

-lost driver side power lock backlight
-lost both driver side heated seat backlights

It never seams to end with this damn truck, ALWAYS something wrong with it... :hissyfit:
 

Sparky

Member
Dec 4, 2011
12,927
So the rest of the headlight switch and the knob is supposed to light up? OK.. mine has been totally dark aside from the little green indicator that sometimes works ever since I got it.

Well, still not going to mess with it...
 

The_Roadie

Lifetime VIP Donor
Member
Nov 19, 2011
9,957
Portland, OR
Denali n DOO said:
It never seams to end with this damn truck, ALWAYS something wrong with it... :hissyfit:
The natural resting state of any thermodynamic system is maximum chaos and broken-ness. The theory of entropy demands it.

When a system works well, it's a mere temporary state to be celebrated like Canada's short summer.

Expecting perfection is a sure way to be disappointed most of the time.
 

NinjuhhNutz

Member
Oct 15, 2012
720
Sparky said:
Heh, that sounds like a trip. My first car (93 taurus) had dancing dash backlights (or front lights I think actually). Never knew which side of the cluster was going to be dark, so I carried an aux light in case both went dark at the same time lol. My Trailblazer's passenger slider light went dark a long time ago, and the little green lights on indicator on the headlight switch is usually dead also, although tapping it or hitting a bump will sometimes light it back up for a short while.

Anyway, maybe you should rip yours apart and do LED conversions. I was going to do that to mine but I don't want to go through the effort :tongue: (I still haven't finished my headlight retrofit I started 2 years ago...:redface:)

at the rate things are going with mine, we'll finish within the same timeline :yikes:
 

Forum Statistics

Threads
23,400
Posts
638,838
Members
18,614
Latest member
dakis

Members Online