Switchback bulb problem??

Kuchar09

Original poster
Member
Dec 4, 2011
150
I recently bought switchback bulbs from ddmtuning and I put them in today. With running lights on they are white and when I turn my blinker on they flash amber but the white stays on. This makes it very hard to see my blinker, so this is not okay.
Before I bought these DDM said that these bulbs will switch back and forth from amber to white when the blinker is on so my question is did I do something wrong?
The first time I put them in they didn't do anything so I put the bulb in the other way and got the results above.
I didn't cut any tabs when I put the bulb in I kind of just twisted it so maybe a prong isn't touching is the only thing I can think of.

http://ddmtuning.com/Products/Switchback-60


This was the question that someone asked on facebook
Dumb question... When these are illuminated as running lights, and you switch to turn signals, does the white turn off while only the amber flashes? Or does the amber flash on top of the white? For example: [video=youtube;2BO41VYGv4I]http://www.youtube.com/watch?v=2BO41VYGv4I[/url][/video] shows the amber flashing over the white.Or do they act more like this.. White turns off when the amber is flashing: [video=youtube;lveqQSP5GjE]http://www.youtube.com/watch?v=lveqQSP5GjE[/video]

Their response was The amber blinks on top of the white.

Heres what I have

[video=youtube;HAtRJAxZUYY]http://www.youtube.com/watch?v=HAtRJAxZUYY[/video]

[video=youtube;8YULs0MuKpc]http://www.youtube.com/watch?v=8YULs0MuKpc[/video]

Any ideas?
 

Wooluf1952

Member
Nov 20, 2011
2,663
Milwaukee, Wisconsin
The last two videos don't work.

When I click on them, they just have a sign that says "This video is private"
 

SBUBandit

Member
Dec 5, 2011
597
Hope someone can figure this out, that's a good price for switchbacks.
 

Blckshdw

Moderator
Nov 20, 2011
10,706
Tampa Bay Area, FL
I would venture to say your switchbacks are faulty. They should either be white as running lights, and then flash amber-off-amber-off for the turn signals, or flash amber-white-amber-white. The white LEDs should not be constant. I bought the Amber-White flashing style from Autolumination last year. :undecided: I need to make a new video...

[video=youtube_share;Vr4XL7hNPP0]http://youtu.be/Vr4XL7hNPP0[/video]
 

Kuchar09

Original poster
Member
Dec 4, 2011
150
Kuchar09 said:
woops thier on private... ill fix it

Blckshdw said:
I would venture to say your switchbacks are faulty. They should either be white as running lights, and then flash amber-off-amber-off for the turn signals, or flash amber-white-amber-white. The white LEDs should not be constant. I bought the Amber-White flashing style from Autolumination last year. :undecided: I need to make a new video...

[video=youtube_share;Vr4XL7hNPP0]http://youtu.be/Vr4XL7hNPP0[/video]

Humm ok I haven't tested the other bulb yet so I'll do that tomorrow.

If that doesn't work either I guess I'll be giving DDM a call. I do know that they just released these bulbs on 10th so I'm assuming I received the first batch and maybe they had some problems.

I was assuming they would work just like yours do... Hopefully they still do once I get my issues resolved.

Thanks for the help, I'll be sure to keep everyone updated.
 

SBUBandit

Member
Dec 5, 2011
597
Seems like the ones Jettt was selling flashed amber-off, rather than amber-white.
 

Blckshdw

Moderator
Nov 20, 2011
10,706
Tampa Bay Area, FL
Yeah, when they first came on the scene, I think the amber-off style was more popular. Luckily the way our corner signals work with the 194 switchbacks, the amber-white style is a perfect match for me. :biggrin: :cool:
 

djthumper

Administrator
Nov 20, 2011
14,956
North Las Vegas
Blckshdw said:
Yeah, when they first came on the scene, I think the amber-off style was more popular. Luckily the way our corner signals work with the 194 switchbacks, the amber-white style is a perfect match for me. :biggrin: :cool:

I swear Carlton is an LED vendor. Maybe he should be to make sure we are all using the correct setup and get paid for his custom work. :smile:
 

Blckshdw

Moderator
Nov 20, 2011
10,706
Tampa Bay Area, FL
My mod bug would be out of control if that was the case
 

Kuchar09

Original poster
Member
Dec 4, 2011
150
I got all the leds in (turn, marker, and mirror) and unfortunately it looks like my switchback bulbs are faulty. I guess I'll be getting in to contact with them soon.
I think it will look good once I get this figured out and will finally have leds all around, well except for the third brake light which I am still thinking about. :undecided:

[video=youtube;0rFcc2aHxlc]http://www.youtube.com/watch?v=0rFcc2aHxlc[/video]

Here are me tail lights I did this summer :biggrin:
Led tail lights - YouTube
 

SBUBandit

Member
Dec 5, 2011
597
Blckshdw said:
Yeah, when they first came on the scene, I think the amber-off style was more popular. Luckily the way our corner signals work with the 194 switchbacks, the amber-white style is a perfect match for me. :biggrin: :cool:

That's true, I forgot the 194 do amber-white as well. Might have to grab some of these then. Did you ever do the 194 switchbacks yet?
 

Blckshdw

Moderator
Nov 20, 2011
10,706
Tampa Bay Area, FL
SBUBandit said:
That's true, I forgot the 194 do amber-white as well. Might have to grab some of these then. Did you ever do the 194 switchbacks yet?

Yep sure did. Which is why I need to make a new switchback video :cool:
 

Kuchar09

Original poster
Member
Dec 4, 2011
150
I have one more problem I would like some input on before I email DDM. I also ordered 4 194 LED 5X5050 amber for my mirrors and side markers on the headlights. I got the mirror lights to work even though the bulbs were slightly too long and I also got the side marker light to light up. I was testing if I had the bulbs in right my turning on my 4 way flashers.
Well when I started the car my side marker bulbs didn't work at all (well they weren't on with the running lights I don't think I tried my blinkers) and I turned the bulbs 180 degrees and they worked fine. After testing different methods I realized the side markers will not light up (as a blinker) unless I have my lights on... Not sure if this is normal or not but something I noticed, Its not a big deal because I always have my lights on.
My issue that I do not like is while driving to the store a night I noticed that my turn signals on my dash were very very dimly lit which makes think something isn't right here. I narrowed the case of this that issue down to the side marker bulbs (I unplugged them and my problem was gone) but don't understand why.
Is this another faulty bulb issue?
My mirror turn signals work fine but those are not running lights.
These are the bulbs I ordered 5X5050 http://www.ddmtuning.com/Products/194-T10-168-LED-Bulb
Thanks for any help guys... starting to think I should have bought these lights from autolumination.com :duh:
 

kardain

Member
Dec 16, 2011
557
Just tossing this out there, but have you tried swapping each 194 to the same socket to rule out a bad bulb?

Also do the 194's function normally if you swap an incandescent 3457 back in?
 

Blckshdw

Moderator
Nov 20, 2011
10,706
Tampa Bay Area, FL
I had to dig into the corner marker light issue when putting switchbacks in there. As you may already know, LEDs are polarized, so they will only work with current flowing in one direction. Our corner sockets are wired in a dual function format. One wire is the + for the turn signal, and uses the other wire (which is the + for the parking light) as a ground. The same works the other way. So when the parking lights are already on, and the turn signal comes on, the 2 currents cancel each other out, and the bulb turns off. This is why the corner turn signal flashes out of phase with the front turn signals.

Getting back to the 194 bulbs, they will only work under one condition, either at night with the parking lights and turn signal, or during the day as turn signal only. This is, of course, unless you build yourself a polarity changer, which may be a bit more involved than you want to get. :crazy: Now as to why it makes the indicators in your cluster light up dimly, I have no idea. Like Kardain suggested, swap those bulbs with the ones in the mirrors, rule out bad bulbs. :confused:
 

Kuchar09

Original poster
Member
Dec 4, 2011
150
Blckshdw said:
I had to dig into the corner marker light issue when putting switchbacks in there. As you may already know, LEDs are polarized, so they will only work with current flowing in one direction. Our corner sockets are wired in a dual function format. One wire is the + for the turn signal, and uses the other wire (which is the + for the parking light) as a ground. The same works the other way. So when the parking lights are already on, and the turn signal comes on, the 2 currents cancel each other out, and the bulb turns off. This is why the corner turn signal flashes out of phase with the front turn signals.

Getting back to the 194 bulbs, they will only work under one condition, either at night with the parking lights and turn signal, or during the day as turn signal only. This is, of course, unless you build yourself a polarity changer, which may be a bit more involved than you want to get. :crazy: Now as to why it makes the indicators in your cluster light up dimly, I have no idea. Like Kardain suggested, swap those bulbs with the ones in the mirrors, rule out bad bulbs. :confused:

Thanks for the info!!

I currently have put the stock bulbs in and everything seems to be working correctly besides 2 burnt bulbs.
I have the leds that were in the mirror separate but I'm contemplating on just sending them all back for a refund and taking my order elsewhere.
 

Kuchar09

Original poster
Member
Dec 4, 2011
150
Well I decided I am not going to give up that easy!!
I went out and switched the marker lights with the mirror light with my stock turn signals and as far as I can tell they are not dimly lit!! :woohoo: I'll have to check once it gets darker out to be sure.
I am going to email DDM tonight about replacement switchbacks and hopefully they were faulty.

Thanks for the help everyone!!!
 

Kuchar09

Original poster
Member
Dec 4, 2011
150
Received an email back from DDM this morning

Hi Travis,
Thank you for the email and videos.
I have spoken to our inventory specialist who is familiar with our LED bulbs and he had informed me that the bulbs you received are working properly after viewing the video. He had informed me that our switch backs have the white part of the LED on at all times, even when you turn on the turn signal.

If you would like to set up a return for a refund, please let us know.​


I guess I will be getting a refund because you cant even see your blinkers when your running lights are on.
Seems kinda pointless to have it that way but oh well at least I tried to save some money :banghead:
 

Blckshdw

Moderator
Nov 20, 2011
10,706
Tampa Bay Area, FL
At least they seem cooperative enough to give you your money back. FWIW, the switchbacks I got from Autolumination also have 60 LEDs, however each one is a dual function LED (has inputs for white AND Amber on the same LED) so when they are on, ALL 60 are either white, or amber, depending on the proper function. Granted they are twice as much as the DDM ones you got, but for twice the light, that seems fair to me. :biggrin:
 

Kuchar09

Original poster
Member
Dec 4, 2011
150
Blckshdw said:
At least they seem cooperative enough to give you your money back. FWIW, the switchbacks I got from Autolumination also have 60 LEDs, however each one is a dual function LED (has inputs for white AND Amber on the same LED) so when they are on, ALL 60 are either white, or amber, depending on the proper function. Granted they are twice as much as the DDM ones you got, but for twice the light, that seems fair to me. :biggrin:

That is the route I am going now once I know I get my money back!!
You have the 60-60 led SMT Stealth Ultimate Switchback Bulbs in Amber-White (AW) then correct?
 

Blckshdw

Moderator
Nov 20, 2011
10,706
Tampa Bay Area, FL
:yes: those are the ones. Something about seeing "Ultimate" in the name drew my attention. :cool:
 

kardain

Member
Dec 16, 2011
557
Thanks for the help everyone!!!

no problem. glad to see things got (mostly) sorted out.
 

SBUBandit

Member
Dec 5, 2011
597
Blckshdw said:
:yes: those are the ones. Something about seeing "Ultimate" in the name drew my attention. :cool:

Now you really need to get a new video. I'm curious how the all amber / all white front signals look with the amber/white 194s
 

Blckshdw

Moderator
Nov 20, 2011
10,706
Tampa Bay Area, FL
SBUBandit said:
Now you really need to get a new video. I'm curious how the all amber / all white front signals look with the amber/white 194s

:laugh: I'll try to get that done and posted this weekend.
 

Forum Statistics

Threads
23,485
Posts
639,862
Members
18,722
Latest member
bigchadwell

Members Online

No members online now.