Stabilitrak Light came on, on drive home.

LouisTB

Original poster
Member
Apr 12, 2016
120
Tampa, FL
So I think the stabilitrak light came on tonight on my drive home from work. Its the light that has a vehicle in a triangle with squiggly lines behind it. I was turning left off the exit ramp and as I was turning the steering wheel back to center I noticed that light started to flash and then went solid and stayed on. I drove for a bit more and pulled over into a gas station and turned off and back on and the light went out. After pulling out of the gas station i turn onto another round this time turning right and the light did the exact same thing the gas station was probably all of a mile from where i turned right. I haven't looked to see if there's a stored code yet might try to do that tomorrow at work. I have changed out the steering wheel position sensor once before, cant remember when that was but it was easily 3 or more years ago. But I'm pretty sure both the service stabilitrak and the stabilitrak lights came on when i replaced it the first time now its just the stabilitrak light coming on and i don't remember the first time either of those lights flashing when they came on. It has been raining pretty heavily everyday for a while down here in Florida but I haven't spun the wheels at all or given the vehicle any reason to activate the stabilitrak. Just wondering if anyone had any insight as to what might be my issue. Thank you.
 

mrrsm

Lifetime VIP Donor
Supporting Donor
Member
Oct 22, 2015
7,594
Tampa Bay Area
This information is right on the money...


The Likely Suspect, its Diagnosis and Repair are very nicely shown here:

 

LouisTB

Original poster
Member
Apr 12, 2016
120
Tampa, FL
This information is right on the money...


The Likely Suspect, its Diagnosis and Repair are very nicely shown here:



Hmmm....hopefully it is that cause that's a pretty easy fix. I forgot to mention I have changed out both front wheel bearings with timenkin wheel bearings and I could of sworn they came with new wheel speed sensors. But still probably not a bad idea to check them out Saturday weather permitting.
 

Mooseman

Moderator
Dec 4, 2011
25,184
Ottawa, ON
This is the usual diagnostic for the Stabilitrak. If only that light is on, then it is likely the steering wheel position sensor. If you have that light as well as the ABS light on, then it's a fault with the ABS system.

The SWPS is the only component that is associated to the Stabilitrak system only. Everything else is in the ABS system. The fact that it would manifest itself when you would turn the steering wheel pretty much confirms this.

And when it does come up, you can cancel it by turning the key to START while driving. If it returns as soon as you turn the steering wheel, that'll be it.
 
  • Like
Reactions: mrrsm and Beacon

LouisTB

Original poster
Member
Apr 12, 2016
120
Tampa, FL
This is the usual diagnostic for the Stabilitrak. If only that light is on, then it is likely the steering wheel position sensor. If you have that light as well as the ABS light on, then it's a fault with the ABS system.

The SWPS is the only component that is associated to the Stabilitrak system only. Everything else is in the ABS system. The fact that it would manifest itself when you would turn the steering wheel pretty much confirms this.

And when it does come up, you can cancel it by turning the key to START while driving. If it returns as soon as you turn the steering wheel, that'll be it.


I'll have to confirm on my way to work but ill try bumping the start while driving if the light goes out. Thanks.
 
Last edited:

LouisTB

Original poster
Member
Apr 12, 2016
120
Tampa, FL
Update: So bumping the key to start while driving did turn the light off. Now it comes back on when I slow down to a stop turning or slowing to stop going straight. Which makes sense since both times it came on that night I was slowing down to a stop they just both happened to be at turns so I chalked it up to it coming on while turning.
 

Mooseman

Moderator
Dec 4, 2011
25,184
Ottawa, ON
My money is still on the SWPS if only the Stabilitrak light is on. You can confirm it with a scanner able to scan other than powertrain codes, a Tech 2 or an ELM327 bluetooth adapter with the Car Gauge Pro app on an Android device.
 
  • Like
Reactions: TJBaker57

Red955i

Member
Sep 10, 2020
37
NYC
This is the usual diagnostic for the Stabilitrak. If only that light is on, then it is likely the steering wheel position sensor. If you have that light as well as the ABS light on, then it's a fault with the ABS system.

The SWPS is the only component that is associated to the Stabilitrak system only. Everything else is in the ABS system. The fact that it would manifest itself when you would turn the steering wheel pretty much confirms this.

And when it does come up, you can cancel it by turning the key to START while driving. If it returns as soon as you turn the steering wheel, that'll be it.

When you say "only" that light are you speaking of a single light? I have both the Stabilink Service Light and the Stabilink Indicator light on. They go off when I restart car. Originally the ABS was activating. When scanner one wheel was showing it was traveling slower on the scanner...I replaced that wheel sensor and it solved that problem. I do get, occasionally a C0455 (Steering Wheel Position) yet on scanner it goes high and low as it should. Shows correct voltage...but....occasionally straight ahead...is not 0 degrees or anywhere close. Just want to make sure its the sensor before I throw $100 at it. There is no what I see to reset it?
 

Mooseman

Moderator
Dec 4, 2011
25,184
Ottawa, ON
That's what I meant. If the ABS light was on with the Stabilitrak light(s), then it's a problem with the ABS system. If only the Stabilitrak light(s) are on, then it's the SWPS. If. You have the scanner, then it's always better to confirm with the actual code.
 

Forum Statistics

Threads
23,233
Posts
637,093
Members
18,397
Latest member
jfon105

Members Online