Sputtering noise in the rear of the truck

guy777

Original poster
Member
Mar 26, 2012
5
Hi everyone. My first post here.

My trailblazer will sometimes make a sputtering noise in the rear of the truck while driving.

The noise sounds electrical as well....... like a small engine noise.

The noise lasts for about 5 secs and happens about 2 times a week and I drive about 500 km a week.

My truck has 273,000 km or 170,000 miles . Could this be my fuel pump?. Its still original.


2003 Chevy TrailBlazer LS
Light Pewter Metallic 4.2L I6 4X4
 

The_Roadie

Lifetime VIP Donor
Member
Nov 19, 2011
9,957
Portland, OR
Welcome!

I assume it's on the left side of the rear? Fuel pumps usually just quit, in my memory of reading years worth of posts on trailvoy.

Have you changed the fuel filter regularly? Does it happen more at full throttle or cruise or ever happen at idle? How about all your other fluids - differentials and transfer case especially? (Every 50K miles on the transfer case, which is often a surprise when owners find out.)
 

guy777

Original poster
Member
Mar 26, 2012
5
I couldn't tell if it was coming more from the left side or right side.

It never happens when idling just when driving at city speeds 30 - 70 km/hr.

Thanks for mentioning about the fluids . I checked my rear differential last night and it was low, about 1.5 to 2 inches below the fill hole!

I will go buy some today and fill it. It gets low because I have a leak on my axle bearings. I will have to get those changed.


Thanks Roadie!!!!!!!!!!!!!!!!!!!
 

308sako

Member
Apr 1, 2012
10
Just found my way here with a divine wind from another site... will not miss the advertizing LOL

This site will return to the GOLD standard, thanks Roadie!
 

Forum Statistics

Threads
23,396
Posts
638,821
Members
18,610
Latest member
Amri

Members Online