"SERVICE BRAKE SYSTEM" LCD warnings, BRAKE and ABS lights on after 200,000 miles

krivraq

Original poster
Member
Mar 3, 2012
19
Shortly after 200,000 miles several weeks ago our dashboard LCD display (Driver Contol Center??) began beeping and warning us to "SERVICE BRAKE SYSTEM" and the BRAKE and ABS lights are intermittent as well. Is this related to an OEM maintenance schedule after 200,000 miles? We've had the truck since 65,000 miles and there have been no such warnings until now.

The brake system works fine, the ABS is functioning, the master cylinder fluid is full, the pads on all four wheel are fine. There are no codes being thrown when I check scanner under driver dash terminal. I've cleared the computer of other codes and removed/replaced battery as well and it still happens.

Any clues???
 

blazinlow89

Member
Jan 25, 2012
2,088
Could be anything from a bad sensor, to really anything. It will be hard to diagnose, unless someone else has had a similar problem.
 

AbsoluteZero

Member
Nov 21, 2011
211
krivraq said:
There are no codes being thrown when I check scanner under driver dash terminal. I've cleared the computer of other codes and removed/replaced battery as well and it still happens.

Any clues???[/COLOR]
I think brake related codes are (C)hassis codes. Unless you have a high-end scanner you probably can't read a Chassis or Body code.
 

The_Roadie

Lifetime VIP Donor
Member
Nov 19, 2011
9,957
Portland, OR
I can guarantee that no maintenance warnings show up because of straight mileage. The OLM (oil life monitor) is partially dependent on mileage, but that's not the only input, so it's not going to pester you at set intervals like on some other platforms.

ABS and brake system intermittent issues are often due to corrosion or looseness in the frame ground lug that gets abused a lot in places that experience winter. :cool:

Check this:

View attachment 19486
 

Attachments

  • 1.jpg
    1.jpg
    66.1 KB · Views: 26

krivraq

Original poster
Member
Mar 3, 2012
19
Thanks for the input, everyone. I'll check that frame terminal/bolt, Roadie, and thanks for the picture.

I'm off to local Advance and whomever else to try a "dealer only" seal by chance. It's Sunday and I need to have a lot of work finished today. Currently, so many different projects on this truck:mad: that I'll need to repost in about 4 other threads to cover them all.

Thanks to all and their efforts on this site.
 

Forum Statistics

Threads
23,388
Posts
638,718
Members
18,595
Latest member
ShowMeStL

Members Online