Rear Hvac blows warm constantly

tjmoffa

Original poster
Member
Apr 4, 2013
12
Searched through many posts and could not find a similar situation. I know its probably simple, but the rear control will adjust the fan speed and modes between floor and roof vents, but the temp will not change and stays warm no matter what the setting on the control. I assume it is a blend door actuator? I have an 03 TB EXT LT with the digi controls if that helps. Front works as expected with the controls both hot and cold. Thanks in advance.
 

The_Roadie

Lifetime VIP Donor
Member
Nov 19, 2011
9,957
Portland, OR
The rear unit has both an airflow mode and a temp actuator. Been discussed a few times both here and on trailvoy. Usually accompanied by this graphic I put together years ago as an aid.

rearactuators-orig.jpg
 

tjmoffa

Original poster
Member
Apr 4, 2013
12
the roadie said:
The rear unit has both an airflow mode and a temp actuator. Been discussed a few times both here and on trailvoy. Usually accompanied by this graphic I put together years ago as an aid.

rearactuators-orig.jpg

I did the reset, still the same situation, though the digital display now starts out very high external temp and comes down to normal temp, i.e. 115F then comes down. Should I replace both actuators or a specific one?
 

The_Roadie

Lifetime VIP Donor
Member
Nov 19, 2011
9,957
Portland, OR
tjmoffa said:
...the digital display now starts out very high external temp and comes down to normal temp, i.e. 115F then comes down.
You might also have a problem with the $5 ambient air temp sensor behind the grill near the hood latch.
Should I replace both actuators or a specific one?
No reason to replace the good one that's controlling airflow. Just the temp actuator that's near the obvious heater core.
 

Forum Statistics

Threads
23,392
Posts
638,779
Members
18,601
Latest member
Chris Moore

Members Online