Rattling sound on idle?

ElAviator72

Original poster
Member
Jan 11, 2012
118
The rattle is back!

Actually, I don't think it ever went away.

It is a bearing kind of rattle, only at idle. The stealership diagnosed it as the water pump (after I asked them to check the fan clutch). A new water pump later, and I'm noticing the same sound. Thought the '07 had an improved fan clutch. Is there anything else it could be? They put a new fan belt on it, too, when they changed the water pump. Noticed it driving around a lake on the forest roads this last extended weekend.:frown:
 

Pittdawg

Member
Dec 5, 2011
538
ElAviator72 said:
The rattle is back!

Actually, I don't think it ever went away.

It is a bearing kind of rattle, only at idle. The stealership diagnosed it as the water pump (after I asked them to check the fan clutch). A new water pump later, and I'm noticing the same sound. Thought the '07 had an improved fan clutch. Is there anything else it could be? They put a new fan belt on it, too, when they changed the water pump. Noticed it driving around a lake on the forest roads this last extended weekend.:frown:

I think they only switched to the new (actually old) clutch fan design in '08.
 

n0kfb

Member
Dec 8, 2011
104
Since I can't actually hear the noise over the computer, I'm going to guess you have a bad bearing in an idler pulley. Remove your serpentine belt(s), and spin each pulley by hand. You will probably easily figure out which one is bad.

-- Dan Meyer :coffee:
 

Forum Statistics

Threads
23,330
Posts
637,990
Members
18,534
Latest member
06_4.2_4x4_ls

Members Online