problem programming key fob

Status
Not open for further replies.

sunliner

Original poster
Member
Mar 25, 2012
365
I have a 2006 Trailblazer LS

Bought it used and it came with a 'generic' remote fob. The fob functions just fine but the plastic ring that attaches it to my keyring broke so I bought a replacement GM fob from Ebay.

The fob came with the standard programming instructions (hold door unlock, cycle the key 2x etc) but I can't get the truck into programming mode.

Immediately as I bring the key back to "off" the second time, the locks cycle, then they cycle again about 5 seconds later. I think they're only supposed to cycle once. I've tried releasing the lock button on the door both before the second cycle and after, then holding the buttons on the remote. cannot get the remote to program.

I know the keyless entry system goes through the liftgate control module on this truck. I noted a while back that the rear wipers don't work, however everything else does-window, power locks and, as mentioned my old key fob works fine.
Any ideas?
 

Mooseman

Moderator
Dec 4, 2011
25,178
Ottawa, ON
Try this:

1. Close all the vehicle doors.
2. Insert the ignition key into the ignition lock cylinder.
3. Press and hold the door unlock switch.
4. While holding the door lock switch in the unlock position, cycle the ignition ON, OFF, ON, OFF.
5. Release the door unlock switch. The doors will lock and unlock to confirm the program mode.
6. Press and hold the LOCK button and the UNLOCK button simultaneously on one transmitter. After a delay of approximately 15 seconds, the doors will lock and unlock to confirm the programming of that transmitter.
7. Repeat the previous step to program up to four transmitters.
8. Turn the ignition switch to the RUN position in order to exit the keyless entry transmitter mode.
9. Operate the transmitter functions in order to verify correct system operation.

Other than that, I might suspect a dead battery or key fob.
 
  • Like
Reactions: Mobileterminaluser

sunliner

Original poster
Member
Mar 25, 2012
365
Thanks Moose...or Mr Man,
But that's exactly the steps I followed. I switched batteries in the new fob with a known good one even. I think I'm failing to get the truck in 'program mode' somehow. I found a video on youtube of the procedure, and I only hear the locks/horn cycle once when the guy on the video does it; when I do it, the locks cycle just as I bring the key back to OFF the second time, before I let go of the unlock button on the door. then a few seconds later the locks cycle again.

I do appreciate your trying to help though.
-Mike
 

Mooseman

Moderator
Dec 4, 2011
25,178
Ottawa, ON
Check the contacts in the remote under the rubber. I've had to clean the metal contacts on the board with a burnishing brush due to corrosion. You could do the same gently with some scotchbrite (the type for bodywork). Also gently clean the carbon contacts under the rubber buttons with isopropyl rubbing alcohol. Check the battery contact on the board and gently clean with scotchbrite, same as the button contacts. The metal top battery holdown has been known to break the solder joints to make sure that the joints are still good (3 of them).

Apart from trying to program the remote, there is no way to check if it works except at the dealer where they may have a tester for them.
 

sunliner

Original poster
Member
Mar 25, 2012
365
thanks, but the remote is fine. the issue is that the truck won't go into programming mode.

I did a little digging around and determined that a previous owner installed an aftermarket alarm system. Great.
I'm only planning on driving this thing another year or so anyway; I rigged it to stay on the keyring for now, and the guy who sold me the replacement remote agreed to give me a full refund even though the issue wasn't his fault--great guy.

thanks
-Mike
 

BRomanJr

Member
Dec 9, 2011
371
sunliner said:
thanks, but the remote is fine. the issue is that the truck won't go into programming mode.

I did a little digging around and determined that a previous owner installed an aftermarket alarm system. Great.
I'm only planning on driving this thing another year or so anyway; I rigged it to stay on the keyring for now, and the guy who sold me the replacement remote agreed to give me a full refund even though the issue wasn't his fault--great guy.

thanks
-Mike

FYI, Not all Trucks came with the Keyless Entry Option, Check for AU0 on glove box sticker.
If yours doesn't have the option, that may be why previous owner opted to install the aftermarket system.

EDIT:
Also, you could look into a replacement aftermarket remote, or even purchase new case for the broken remote. I did this once, found a replacement case on e-bay, took the workings (technical term) out of the old broken case and into the new, worked perfect.
 

Jason138

Member
Aug 29, 2013
16
Hi guys I'm having the same problem, when entering program mode the vehicle will exit program mode seconds late even before I let go of the unlock switch. Regardless if I let go after it enters program mode it will cycle off every time. Has anyone figured out a solution? I'm sure I can take it in to the dealership, but I'm not sure I'm willing to pay the $120 they are asking.

thanks,
J:thumbsup:
 

Mooseman

Moderator
Dec 4, 2011
25,178
Ottawa, ON
What does it do exactly when trying the steps above? How can you tell if it went out of programming mode? Is the fob you're trying to program new or used? Maybe it's dead or the contacts need to be cleaned, battery replaced or the clip re-soldered.

Stupid question: Did your truck originally come with one?
 

Jason138

Member
Aug 29, 2013
16
Mooseman said:
What does it do exactly when trying the steps above? How can you tell if it went out of programming mode? Is the fob you're trying to program new or used? Maybe it's dead or the contacts need to be cleaned, battery replaced or the clip re-soldered.

Stupid question: Did your truck originally come with one?


When exiting program mode the doors locks cycle on/off and the horn will beep twice. One beep and a cycle means your entering program mode 2 beeps + cycle means your exiting. The Key fob's are bran new, ordered from the dealership and new batteries installed. Just not sure why it keeps exiting only secs. after entering. I've tried multiple times, same scenario each and every time.
 

C-ya

Member
Aug 24, 2012
1,098
  • Like
Reactions: Mikey71

BRomanJr

Member
Dec 9, 2011
371
Jason138 said:
When exiting program mode the doors locks cycle on/off and the horn will beep twice. One beep and a cycle means your entering program mode 2 beeps + cycle means your exiting. The Key fob's are bran new, ordered from the dealership and new batteries installed. Just not sure why it keeps exiting only secs. after entering. I've tried multiple times, same scenario each and every time.

Do you have the Keyless Entry option?
Not all Trucks came with this Option, Check for AU0 on glove box sticker.

Many GM vehicles omit the passenger Door Exterior Keylock cylinder when you have Keyless Entry, another way to tell.
 

Jason138

Member
Aug 29, 2013
16
BRomanJr said:
Do you have the Keyless Entry option?
Not all Trucks came with this Option, Check for AU0 on glove box sticker.

Many GM vehicles omit the passenger Door Exterior Keylock cylinder when you have Keyless Entry, another way to tell.

I'll have to check that out, never thought that it might have been an option on this vehicle. I'm the second owner of this vehicle, and it didn't come with the original key nor any Key Fob's.

I've also read another way to tell is by the passenger side door panel, if there is a lock then it has RKE installed. If no lock no RKE, any truth to this? Not really a big deal to me since my previous car's remote went out years ago, kinda got used to using my key to open the doors anyways. Just figure if it was an option I would like to have that option.
 

Mark20

Member
Dec 6, 2011
1,630
Jason138 said:
I'll have to check that out, never thought that it might have been an option on this vehicle. I'm the second owner of this vehicle, and it didn't come with the original key nor any Key Fob's.

I've also read another way to tell is by the passenger side door panel, if there is a lock then it has RKE installed. If no lock no RKE, any truth to this? Not really a big deal to me since my previous car's remote went out years ago, kinda got used to using my key to open the doors anyways. Just figure if it was an option I would like to have that option.

Other way around. No lock cylinder on passenger door then you have RKE. At least that's the way it is on my Voy & Silverado.
 

Jason138

Member
Aug 29, 2013
16
Mark20 said:
Other way around. No lock cylinder on passenger door then you have RKE. At least that's the way it is on my Voy & Silverado.

Well doesn't that just suck, oh well my buddy who runs a Car Toy's owes me a favor still I'll be paying him a visit soon need a entire new stereo and might just get an alarm system installed to. Thanks for the info gent's. :biggrin:
 

Mooseman

Moderator
Dec 4, 2011
25,178
Ottawa, ON
Ditto. Just looked and I don't have a keyhole on passenger side with RKE.
 

Jason138

Member
Aug 29, 2013
16
Mooseman said:
Ditto. Just looked and I don't have a keyhole on passenger side with RKE.

Maybe I'm confused or mistaken, but read the glove box tag and it has listed AU0. Doesn't that mean I have RKE installed?

Also I do not have a locking cylinder on the passenger side door.
 

Mark20

Member
Dec 6, 2011
1,630
Then you should have the system.
 

Jason138

Member
Aug 29, 2013
16
Mark20 said:
Then you should have the system.

OK now that we've established and confirmed that I do have RKE installed. So know were back to where I stated, same thing happens every time, enter program mode 3 secs later it exits automatically.

Any thought.......
 

Alansd

Member
Feb 12, 2014
102
good info here. I saw it too late. I figured if the TB had power locks it woudl have keyless. I ordered two new aftermarket fobs, could not program them. Anyone need a couple? I don't show that code on my glovebox. So it goes.
Message me if you can use these.
 

TADave

Member
Feb 18, 2016
14
S.W.Florida
Was there ever an update to this? I'm having the same issue with my 03, as you cycle the key the second time the locks cycle and the horn beeps before releasing the unlock button. (instructions say if it does this keep trying) I looked I have the AU0 option, and no lock in the passenger side door.
I have two brand new remotes, so chances are both aren't defective.
 

rroscher

Member
Jun 1, 2016
1
Missouri - for now
I am having getting my Tahoe in to programming mode here are the steps that i have followed

1. Close all the vehicle doors.
2. Insert the ignition key into the ignition lock cylinder.
3. Press and hold the door unlock switch.
4. While holding the door lock switch in the unlock position, cycle the ignition ON, OFF, ON, OFF.
5. Release the door unlock switch.

and nothing happens...

any suggestions?

I took it to a chevy dealer and they told me that i'd have to track down the problem, so here i am.

thanks Robert
 

Mooseman

Moderator
Dec 4, 2011
25,178
Ottawa, ON
Unfortunately, this is a thread for Trailblazers and Envoys (360/370), not the full size trucks. Instructions may be different.

And the DEALER couldn't help you???? Geez!
 

Mooseman

Moderator
Dec 4, 2011
25,178
Ottawa, ON
This is an old thread that was never updated. Just brought back from the dead by those asking "any updates?"

Unless someone has an update, it will be locked.
 
Status
Not open for further replies.

Forum Statistics

Threads
23,229
Posts
637,063
Members
18,390
Latest member
jgriff

Members Online