NEED HELP P0014 2013 Chevy Equinox (2.4L)

brianlibby791

Well-Known Member
#1
My Dads equinox has been getting the P0014 code for the “B” Camshaft position - Timing over advanced or system performance (Bank 1). I’ve been reading up on this code and the issues pertaining to it and symptoms. The car as of right now is not showing any symptoms.

If anyone knows the 2.4L ecotec, you know how they like to go through timing chain guides and hopping the timing chain from them wearing. Would this be just enough to set off a code if it senses it being loose?

I was thinking maybe it’s just the sensor on it’s way out and it tripping itself, because the car has not had any misfire codes or any other symptoms pertaining to the code.
 

littleblazer

Gold Supporter
#2
Crush it.
 
OP
OP
brianlibby791

brianlibby791

Well-Known Member
#3
#4
If the sensor is cheap and easy to get to, I'd be tempted to start by swapping it since it runs OK.

I did not know the 2.4L was prone to timing chain guide issues.
 

littleblazer

Gold Supporter
#5
Wish the Tech II would work on it...
 
OP
OP
brianlibby791

brianlibby791

Well-Known Member
#6
If the sensor is cheap and easy to get to, I'd be tempted to start by swapping it since it runs OK.

I did not know the 2.4L was prone to timing chain guide issues.
Yes they are, kinda sucks because they go out pretty quick (120k on my dads). For the $30 for the sensor im gonna see if he wants to replace that first. I do also wanna go through more diagnosing if there is anything i can do.
 
#7
Were the guides and related stuff improved/fixed in later years?
 

littleblazer

Gold Supporter
#8
You may be able to throw a scope on it.
 
OP
OP
brianlibby791

brianlibby791

Well-Known Member
#9
Were the guides and related stuff improved/fixed in later years?
Not that i am aware of unless they got rid of the plastic guides and replaced then with stronger.
 
OP
OP
brianlibby791

brianlibby791

Well-Known Member
#10
#11
OP
OP
brianlibby791

brianlibby791

Well-Known Member
#12
#14
OP
OP
brianlibby791

brianlibby791

Well-Known Member
#15
Might just throw the $30 sensor on it before making any rational decisions. I hate throwing parts at things but i cant get enough data on it.
 
#16
Might be borderline or that one was already on the new data bus scheme so basically the Tech 2 is unable to communicate with it.
 
OP
OP
brianlibby791

brianlibby791

Well-Known Member
#17
Might be borderline or that one was already on the new data bus scheme so basically the Tech 2 is unable to communicate with it.
Basically. @littleblazer had to use a separate obd2 scanner to pull the code.