oil change now engine light flashes

nbenjamin

Original poster
Member
Dec 7, 2011
76
did the oil change now i noticed the engine light flashed , quick that i just noticed it ....no code
 

MacMan

Member
Mar 3, 2012
194
nbenjamin said:
did the oil change now i noticed the engine light flashed , quick that i just noticed it ....no code
Did you re-set the oil change reminder?
 

Wooluf1952

Member
Nov 20, 2011
2,663
Milwaukee, Wisconsin
MacMan said:
Did you re-set the oil change reminder?


^^ That^^

Is it the oil can and wrench light that's flashing? Reset the OLM.

If it's the Check Engine Light flashing, don't drive it until you know what the code is.
 

nbenjamin

Original poster
Member
Dec 7, 2011
76
Wooluf1952 said:
^^ That^^

Is it the oil can and wrench light that's flashing? Reset the OLM.

If it's the Check Engine Light flashing, don't drive it until you know what the code is.

Yes I did reset the OLM . It flash so fast a couple , I had to turn the ignition after I stop and it could only be the engine light. It's intermittent and is very quick. I will see if it does it again on the way home. The o ly other thing I did do yesterday was fill up gas after the oil change

And I did check for codes. None present
 

Gevans17

Member
Jan 8, 2012
63
nbenjamin said:
Yes I did reset the OLM . It flash so fast a couple , I had to turn the ignition after I stop and it could only be the engine light. It's intermittent and is very quick. I will see if it does it again on the way home. The o ly other thing I did do yesterday was fill up gas after the oil change

And I did check for codes. None present

Make sure your gas cap is tight.
 

Spalding1028

Member
Jan 20, 2012
60
Wooluf1952 said:
^^ That^^

Is it the oil can and wrench light that's flashing? Reset the OLM.

If it's the Check Engine Light flashing, don't drive it until you know what the code is.

Sometimes you need to drive it for it to set a code
 

gunrock

Member
Mar 27, 2012
22
Funny I thought that same thing today...flashing so fast I couldn't see it. It ended up being the tail gate was shut enough to not trip the sensor unless there was enough vibration to turn the rear gate ajar light on.

gunrock
 

Forum Statistics

Threads
22,953
Posts
634,063
Members
17,938
Latest member
TrailblazerLTExtended

Members Online

No members online now.