main wiring harness - o2 sensors?

Does anybody know which wires in the harness that come through the firewall carry the o2 sensors signals? I was getting a MIL with codes P0053 for both banks. Replaced both sensors with brand new Delcos, but im still getting the codes. Do to an older mishap I'm thinking it might be the wires in the harness.
 
OP
9

954interisti

Member
I appreciate the link, but I couldn't make heads or tails of the wiring diagram in regards to what carries the signals from the o2 sensors.
 

The_Roadie

Founding Member
Administrator
As far as I know, the O2 sensors connect directly to the PCM, which is in the engine compartment. Those wires don't go through any hole in the firewall

The schematics should have all the information necessary to trace the wiring. FInd the sensors, and the other end of the signals will be connectors at the PCM. Schematics hardly ever have exact harness ROUTING diagrams, so you have to trace them physically, and by wire color. It's tedious, yes.
 

AtlWrk

Well-Known Member
Did you check fuse #29 (O2 SNSR)? That supplies power to the heating elements of both oxygen sensors and would throw the P0053 if blown. I would then check for 12V (with the ignition in RUN) on the pink wire (terminal D) at the O2 sensor connector.
 
OP
9

954interisti

Member
I appreciate the help guys. I will check the fuse when I head out to the truck later, and if thats not the issue, I'll have to climb under it the truck this weekend to check the connector. I'll post back with an update. Thanks again!
 

Online statistics

Members online
2
Guests online
89
Total visitors
91

Members online

Forum statistics

Threads
21,557
Messages
613,923
Members
15,618
Latest member
iceref63

Secure Browsing

Top Bottom