Idler pulley whine

03TB93

Original poster
Member
Mar 25, 2012
341
Hey guys, Ive read alittle about the idler puller around Trailvoy and GMT. This is the thing that makes the whine that makes the TB (Idk if the envoy has this problem as well).. But anyway, is this what causes that whining that almost sounds like a shitty broken turbo or something?? im thinking im gonna Replace it if that is the cause. Has anyone on here dont this? Is so..
1. was it worth it?
2. Doesnt it cost around $12
3. How long did it take you to put in?

Any other word of advice/comments/Ideas are much appreciated as always :cool:

Thanks fellas/Ladies
-Dan :thumbsup:
 

Mooseman

Moderator
Dec 4, 2011
25,650
Ottawa, ON
It's not a difficult job and not that expensive. It will quickly confirm if it is the idler. Could also be the belt tensioner bearing failing, which would make a similar noise. One thing you could do before is just take the belt off and spin them by hand. You should feel if they are getting rough/dry or have play in them.
 

Wooluf1952

Member
Nov 20, 2011
2,663
Milwaukee, Wisconsin
My Envoy has a whine, but when I got out my stethoscope, the sound is coming from the alternator.

The idler and tensioner pulleys are quiet.
 

Sparky

Member
Dec 4, 2011
12,927
1) make sure engine is OFF
2) take off belt
3) spin each pulley by hand
4) the one that feels like gravel is shot

Hopefully it is just the idler or tensioner pulley. If it is the tensioner pulley you can replace just the pulley and not have to do the whole arm. I just forget the exact part number you want...

In my case the first time my alternator was going out. I replaced the idler and tensioner pulleys first, and the noise didn't go away, so then I dug deeper, found the alternator felt like rocks inside, and replaced it. Whine was gone.

Whine is back again, this time the AC pulley bearing. I've just been living with it until I get all my bits-n-pieces ready to go to take care of it and a few other things that I might as well do while it is all apart :crazy:
 

03TB93

Original poster
Member
Mar 25, 2012
341
Dam sparky.. its always something right. haha

And thanks guys, im gonna give them a spin later and see. Hopefully its nothing too bad like the alternator. I will deffintly let you know tho. Thanks again for the help.
 

Forum Statistics

Threads
23,480
Posts
639,810
Members
18,707
Latest member
obd

Members Online