Hid failed

jrSS

Original poster
Member
Dec 4, 2011
3,950
Start truck up this morning all HIDS fired. Then it went off. (Driver side). Turn light switch on and off...nothing. DAMN IT!!! that's why I hate HIDS. So I am thinking bad ballast. Brand freakin new. VVME brand. Havent had time to look at anything since I was off to work. On the plus side my HID fogs work awesome. Fml
 

dmanns67

Member
Apr 3, 2013
32,979
Ohio
Swap your ballasts, problem will always follow the bad component. You definitely get what you pay for when it comes to HID kits.
 

jrSS

Original poster
Member
Dec 4, 2011
3,950
Well if it's a failed ballast that's what a 1 yr warranty is for. The majority of people I know on this forum run the VVME h i ds with no issue.
 

HARDTRAILZ

Moderator
Nov 18, 2011
49,665
Make sure everything is plugged in tight. That was the only issue I ever had w VVME over the 2.5 years I have used them. I have unplugged them and got them plugged in but loose. Once I pushed it in fully...back to perfect.
 

smitty5150

Member
Nov 18, 2011
1,069
Check connections, priorities, etc. You might want to invest in a relay harness, it can save you a lot of aggravation throughout the life of the components.
 

jrSS

Original poster
Member
Dec 4, 2011
3,950
smitty5150 said:
Check connections, priorities, etc. You might want to invest in a relay harness, it can save you a lot of aggravation throughout the life of the components.

I have a relay harness
 

STLtrailbSS

Member
Dec 4, 2011
1,617
I have had a lot of issues with VVME on 3rd ballast I will be switching when this one fails......$18 ebay brand in my fogs not a god damn issue :mad:
 

jimmyjam

Member
Nov 18, 2011
1,634
i have vme's lows and fogs, only had a problem once and it was a faulty ground connection. as stated, swapping ballasts will demonstrate if its a ballast or wiring issue.
 

DDonnie

Member
Mar 26, 2012
2,631
I blame baricua
 

Boricua SS

Member
Nov 20, 2011
3,080
Ohio
DDonnie said:
I blame baricua

It's BORICUA! :raspberry:

dmanns67 said:
That is typically the culprit. Hopefully it is still under warranty. What does a new VVME ballast run price wise?

2 yr warranty on VVME components.. and a new ballast is $20 bucks... first time in 3 years my 1 low beam VVME ballast just went bad and I ordered one before the big midwest meet..
 

jrSS

Original poster
Member
Dec 4, 2011
3,950
Its not juans fault. It worked the whole time at the big west meet. And then nothing. Thanks for the help juan.
 

Boricua SS

Member
Nov 20, 2011
3,080
Ohio
jrSS said:
Its not juans fault. It worked the whole time at the big west meet. And then nothing. Thanks for the help juan.

No problem bro... you are now an HID pro :thumbsup:
 

Wishbone

Member
Dec 5, 2011
343
So did you replace it with the one you were going to give me? FML :confused:
 

Forum Statistics

Threads
23,400
Posts
638,838
Members
18,614
Latest member
dakis

Members Online