Help with an ABS code C0237

irwinmb5

Original poster
Member
Dec 8, 2011
20
Yesterday my truck had the SES light come on and it gave me a ABS C0237 and a P0128. My TB is a 2003 2wd with 152k on the clock. I thought it had been running cool (and bad mpg's), but the code confirmed, so I went ahead and ordered the thermostat and ECT sensor, so that will be fixed when my parts get in. I changed my thermostat about 20k ago and didn't know about the temp sensor until after I changed it out. I believe it is the sensor going bad, but I might as well knock them both our and be certain I fix the problem.

The ABS code has me stumped though. I did a few searches on here and trailvoy with not much information on this code. I did see that this points to the VSS, but my speedo is still working. I checked all connectors on the ABS module and VSS and everything seems intact. I also read to check the ground on the ABS module, so I did that last night. I also checked my abs function and it seems to be working as well. If everything is working properly, should i worry about this error code? Anybody have any suggestions on this as my knowledge on the braking system is very limited, but I am handy if you have any troubleshooting methods to try. Any help would be appreciated.
 

irwinmb5

Original poster
Member
Dec 8, 2011
20
The ses turned off yesterday while driving. Anybody have any ideas on the ABS code?
 

Wooluf1952

Member
Nov 20, 2011
2,663
Milwaukee, Wisconsin
The 2003 service manual reads;
" C0237
The EBCM detects an erratic rear wheel speed signal for 105 milliseconds."

IIRC, there is just one VSS that covers both rear wheels, and it's in the transmission.

You will still have complete brakes even if the ABS isn't working, but you tested the ABS and it still works.
Others will reply. Good luck.
 

The_Roadie

Lifetime VIP Donor
Member
Nov 19, 2011
9,957
Portland, OR
You can inspect the wiring harness from the VSS at the transmission tailpiece to see if you have rubbing or a rock ding.
 
Dec 16, 2011
110
the roadie said:
You can inspect the wiring harness from the VSS at the transmission tailpiece to see if you have rubbing or a rock ding.

I just got this code, along with a C0281. Any idea why it sets the CEL rather than the ABS warning light? And what is a C0281?
 

CaptainXL

Member
Dec 4, 2011
2,445
UMEXT said:
I just got this code, along with a C0281. Any idea why it sets the CEL rather than the ABS warning light? And what is a C0281?

ABS light would just come on for ABS problems. What you probably have is a bad brake switch, broken wiring somewhere or the CHMSL is not working.
 

Forum Statistics

Threads
23,225
Posts
637,042
Members
18,380
Latest member
SpencerT

Members Online