Blitzed Hvac HELP!!

Jeenyus

Original poster
Member
Jan 7, 2012
12
wooohoo!! first post on the new site!!
and might I add, a very clean and easy site to navigae!


here goes...

I have an 05 envoy slt with the full auto hvac and have been experiencing some issues.

The other day i shut the truck off and the fan kept going so i did the usual on and off until i ended up just pulling the fuse and going to bed. I found the post on "the other forum" about the blower resistor pack/ module so i went and picked up the module from my buddy at gm.

i installed the new module as directed and the fan stopped blowing when truck was off 'whew!' .......BUT..... now this is where its unusual, if the hvac controls are off before the truck is started and i start the truck and turn the hvac on it works fine through all settings speeds and temps, but if i shut hvac off while truck is running and try to turn it back on, it turns on but doesnt blow, same thing if the hvac controls are left on when the truck is shut off and restarted with them on.. it just doesnt blow.

I tried disconnecting the battery, pulling the hvac fuses, and even the ignition fuses but it still reverts to the same weird thing.

If its easier to understand i can video what im talking about and youtube it for anyone interested .

any info is greatly appreciated!!
 

fadyasha

Member
Dec 21, 2011
1,134
Jeenyus said:
wooohoo!! first post on the new site!!
and might I add, a very clean and easy site to navigae!


here goes...

I have an 05 envoy slt with the full auto hvac and have been experiencing some issues.

The other day i shut the truck off and the fan kept going so i did the usual on and off until i ended up just pulling the fuse and going to bed. I found the post on "the other forum" about the blower resistor pack/ module so i went and picked up the module from my buddy at gm.

i installed the new module as directed and the fan stopped blowing when truck was off 'whew!' .......BUT..... now this is where its unusual, if the hvac controls are off before the truck is started and i start the truck and turn the hvac on it works fine through all settings speeds and temps, but if i shut hvac off while truck is running and try to turn it back on, it turns on but doesnt blow, same thing if the hvac controls are left on when the truck is shut off and restarted with them on.. it just doesnt blow.

I tried disconnecting the battery, pulling the hvac fuses, and even the ignition fuses but it still reverts to the same weird thing.

If its easier to understand i can video what im talking about and youtube it for anyone interested .

any info is greatly appreciated!!

Wow I'm not the only one with a haunted TB! First off welcome to the site! I did have a similar problem that my HVAC had a mind of it's own. Out of the blue it would just start by itself. Thankfully my solution to that was to disconnect the battery and it solved the problem! :biggrin:

I'm sure some experts will be chiming in more on the electrical side of things. That was never my strength :redface:
 

The_Roadie

Lifetime VIP Donor
Member
Nov 19, 2011
9,957
Portland, OR
Welcome!

Very odd set of symptoms I never heard of in my six years answering questions. Do you have a meter and some electrical troubleshooting experience? What I would do is check the voltage at the two wires going to the blower motor. If you have voltage and the blower isn't spinning, that pretty much rules out the electronics and the wiring. If you don't have good voltage (that varies with the commanded fan speed) your ground at the blower motor could have a problem, or the new module, or the control unit in the dash. The motor could also have high bearing friction, and you can pull it out and check it on your workbench with 12V.
 

Jeenyus

Original poster
Member
Jan 7, 2012
12
Thanks for the info guys!

I will unhook the battery again today and try it again, if that doesnt work, ill re and re everything again.(blower, module and all plugs) and bench test.

Hopefully I can find my meter to test all the plugs!
 

Forum Statistics

Threads
23,480
Posts
639,807
Members
18,707
Latest member
obd

Members Online