B2AAA OBDC code

ptrkptz

Original poster
Member
Mar 20, 2012
20
Does any one know where I can find any information this code?? I have searched the 'net but can't find a definitive answer.
I know that this is not the proper forum for this (as it was on a Sierra), but I was (am again) an Envoy owner and i know there is a ton of ppl on here that are quite knowledgeable.

Details... I was driving a highway... all the sudden chiming started, i looked down at the instrument cluster, and is said "stop engine low oil pressure"... so i shut it off and pulled off the road, got out, looked underneath, nothing dripping, check the oil level and all was ok. At this point the Check engine soon light was not on. I started it back up and at idle had ~40 lbs of oil pressure. Sat for a second and took off again. Within a few minutes of driving (~60 mph), i could see the gauge begin to drop, and the Check Engine light came on. Drove about 10-20 miles and the chimes started again and the low oil message appeared. Pulled off again, and sat for a bit, luckily i had my ScanGauge II hooked up and found the code 'B2AAA'. Throughout this, I am out in the country and no cell service. Started back up and took off, few miles later, the same.
Finally, got it to a gas station and called the dealership. The dealership came (~50 miles away) and picked it up, and returned my Envoy. They told me they would check it out and let me know.

But at this point i am curious... and can't find any info.
 

Wooluf1952

Member
Nov 20, 2011
2,663
Milwaukee, Wisconsin
Got this from Google (in 0.41 sec) :wink: :

Hi guys, my SEL came on couple of days ago, hooked up my obd-2 scanner and it
pulled up B2AAA code. Unfortunately that code means nothing.. so I took it into
the dealer and they said it was actually P0420, made appointment for service
Tuesday. 2011 LML with just over 10,000mi. First problem with the truck.
 

ptrkptz

Original poster
Member
Mar 20, 2012
20
Thanks Wooluf... i will have to remember that... B2AAA="we have no idea"

wonder why the scanners can't decipher??
 

The_Roadie

Lifetime VIP Donor
Member
Nov 19, 2011
9,957
Portland, OR
That's an excellent question to post or email the Scangauge folks.
 

ptrkptz

Original poster
Member
Mar 20, 2012
20
Roadie,

that is exactly what I was gonna do, but waiting for the shop to get back to me on the real code.
 

Irishboy02

Member
Apr 1, 2012
222
Any updates on this? I am an avid scangauge user, and own a seirra. Wonder if this is a OBD reading issue with the Sierra (i might experience something too) or the scangauge screwing up (something i might have to deal with too)
 

ptrkptz

Original poster
Member
Mar 20, 2012
20
I am kinda disappointed in scangauge... I have sent three messages to them, and still no reply.

I like Scangauge, but at this point, there Customer Svc is kinda angers me. If it is an issue and they don't know how to fix it I wish they would just come out and say it.

Gonna send another message to them... tonight. Either they will get pissed at me and tell me they don't know, or tell me to piss-off. :smile:
 

ptrkptz

Original poster
Member
Mar 20, 2012
20
This is the answer that I received... very disappointing. :mad:

"This code may be the result of a vehicle specific code. As the ScanGauge can only read OBDII standard codes, it may be reporting this instead of the actual code."
 

Forum Statistics

Threads
23,400
Posts
638,838
Members
18,614
Latest member
dakis

Members Online