alternator problem?? or fuel pump??

Ahawki

Original poster
Member
May 23, 2013
5
Truck won't start sounds like it's trying I don't hear my fuel pump;but my battery keeps dying and engine light is on.My My battery has been been dying on me for a couple of months.
 

CaptainXL

Member
Dec 4, 2011
2,445
The first thing to do would be to replace the battery. Then with the key on and engine off listen for the pump whirring away back by the drivers side rear wheel. Check the fuel pump fuse next and see if it's blown.

If you still don't hear anything try kicking or beating on the bottom of the tank with a rubber mallet. See if that kick starts the pump.

Are you familiar with checking for voltage and fuses?

Please fill out your profile more completely so we can help better.

...and welcome to the forums!
 

jonbo2002

Member
Sep 27, 2012
213
sounds like first off if your battery has been bad for a while, if its not getting charged it may be your wiring or the alt took a crap. you may not have enough power to get it started. have you tried jumping it? I would start by pulling the battery and alt and have them tested by auto zone or other parts store. also your profile info would help so we knew what you were driving. as for the fuel pump, I myself have not ever noticed mine so someone else might know if its a noticable sound with the key on.
 

jonbo2002

Member
Sep 27, 2012
213
CaptainXL said:
The first thing to do would be to replace the battery. Then with the key on and engine off listen for the pump whirring away back by the drivers side rear wheel. Check the fuel pump fuse next and see if it's blown.

If you still don't hear anything try kicking or beating on the bottom of the tank with a rubber mallet. See if that kick starts the pump.

Are you familiar with checking for voltage and fuses?

Please fill out your profile more completely so we can help better.

...and welcome to the forums!

lol yea what Captain said :iagree: we must have been typing at the same time
 

jonbo2002

Member
Sep 27, 2012
213
jrSS said:
Replace battery. And yes... the only awd trailblazer is the SS.

ok now 3 people say the same thing, let us know if it fixes your problem. yes I was being a smart ass with the AWD question. I have been doing auto salvage for 11 years now so have seen a couple TB's in my time :thumbsup: it's one of the main reasons I went and got my TB a little over a year ago.
 

Ahawki

Original poster
Member
May 23, 2013
5
Thanks for the info captain XL and jonbo2002. I got a jump and charged my battery still nothing. I had someone check my fuses and that's good but I don't hear my pump come on which this guy said he can,but it's A sound I'm very familiar w ith. I'm very frustrated !where I'm from no one seems to know much about these trucks u would think their foreign or something. I'm gonna replace my battery like u guys suggested. And by the way jonbo2002 your are correct smart ass its a 4x4. P.S. Any more suggestions would be helpful
 

jonbo2002

Member
Sep 27, 2012
213
Hey has to raz a fellow Michigander, is the battery holding a charge or not taking a charge at all? If you don't know have it tested before you replace it. That is going to be your best start with the info you gave us we all think its the battery. Let us know if it dosen't work and we will see whatelse we can come up with.
 

Forum Statistics

Threads
23,234
Posts
637,113
Members
18,398
Latest member
DR.B

Members Online