A big THANK YOU to GMTNation!

snowbear

Original poster
Member
Dec 5, 2011
54
Thank you, folks, for saving me a headache! :thumbsup:

Monday, we had to get our son to the airport for a school trip. Wife was at work (about 45 minutes away), the airport is about 1 to 1-1/2 hours, depending on traffic. When my wife tries to leave work, she calls saying the TB won't start and the key won't come out of the ignition. I thinking ignition switch, and how I'm going to get another vehicle (we only have the TB), and get the switch replaced, all in time to get to the airport.

After my initial panic, I searched here and found a thread about the battery causing both conditions. In the meantime, Miriam found a friend to give her a jump and got things going. After a replacement battery was installed in the parking lot of the store, we were able to get the world traveller to the airport.
 

Denali n DOO

Member
May 22, 2012
5,596
:iagree: GMTNation is truly an amazing place to be! You had an issue, came here for a quick peek and right away you basically knew your issue and solved it. In my short time here I have saved about $1600+ by fixing things myself with help of the members here. Quick responses and members that stay with the thread until you succeed. Hats off to GMTNation and all the members that make this place what it is:tiphat: , thankyou from me as well!!!
 

The_Roadie

Lifetime VIP Donor
Member
Nov 19, 2011
9,957
Portland, OR
Glad you're back up. Was the battery on its last legs (age and mileage?) or could it be a parasitic drain that did it in? Just making sure you don't have a lingering issue that could strand you later.
 

snowbear

Original poster
Member
Dec 5, 2011
54
the roadie said:
Glad you're back up. Was the battery on its last legs (age and mileage?) or could it be a parasitic drain that did it in? Just making sure you don't have a lingering issue that could strand you later.
Sorry it's taken so long to get back. It looked like the original 2008 battery (we bought the truck used in December 2010) - milage is around 63,000. So far, this has been to only problem except for the a few lights in the HVAC temperature slider and radio.
 

Menthol

Member
Dec 8, 2011
177
CdnGMan said:
Yup... same here... most of mine have blown out too... I just navigate by feel now... :wink:

You just feel for the slot ..........................on the slider that is. :wink:
 

Forum Statistics

Threads
23,438
Posts
639,266
Members
18,655
Latest member
Jaywebb25

Members Online