Weird Battery Issue

Vicompc

Original poster
Member
Dec 5, 2011
109
I started the TB (started fine) drove 5 miles came out and the TB was dead. No lights, gauges anything, I had it towed to the dealer they are saying it is a dead battery. I've never had a battery go bad with no warning or indication it was failing, is there anything elese this could be?:confused:
 

christo829

Member
Dec 7, 2011
505
Fairfax, Virginia
I had one in my old S10 that died that suddenly. Got me to work, and when I went back out at the end of the day, it was dead, and
I hadn't left anything on. So it can happen.

Could also be ignition switch or bad ground.

How old was the battery?

Good Luck!

Chris
 

Matt

Member
Dec 2, 2011
4,029
I'm with Chris...I've had a battery just go dead before.
 

The_Roadie

Lifetime VIP Donor
Member
Nov 19, 2011
9,957
Portland, OR
A meter would tell you in ten seconds. Assume you don't have one if towing to the dealer was your first choice of repair shops. :frown: Plenty of things it "could" be. Don't you trust the dealer? :confused:
 

Vicompc

Original poster
Member
Dec 5, 2011
109
It's not that I don't trust the dealer I just have never had a battery go south that fast, it was stone dead when I got in the truck. Usually a battery will give you some kind of indication it's going out, this one just went. The only reason the dealer has it is becuase it's still under warranty.
 

Vicompc

Original poster
Member
Dec 5, 2011
109
Vicompc said:
It's not that I don't trust the dealer I just have never had a battery go south that fast, it was stone dead when I got in the truck. Usually a battery will give you some kind of indication it's going out, this one just went. The only reason the dealer has it is becuase it's still under warranty.

Ok just got the truck back from the dealer and when pulling into my driveway the truck died. Nothing on, no dash lights, radio etc. I was able to restart it though, any ideas if this could be the switch?
 

Voymom

Member
Feb 3, 2012
2,523
Vicompc said:
Ok just got the truck back from the dealer and when pulling into my driveway the truck died. Nothing on, no dash lights, radio etc. I was able to restart it though, any ideas if this could be the switch?

Did you get the new battery? Also, I have had a battery just take a complete crap on me without any warning as well. Not in the lemvoy but in a beretta.
I'm wondering if it's not a connection issue somewhere? Maybe someone else more gifted than me can chime in.
 

David B.

Member
Dec 5, 2011
51
Funny timing for this thread, was just telling my buddy in the office the story of yesterday morning- I went out to start the TB for work, completely dead. Like no juice whatsoever. This was my first time having one go completely out without any warning, it had been working great the night before! Odd in my experience, but I have a nice new battery now LOL
 

The_Roadie

Lifetime VIP Donor
Member
Nov 19, 2011
9,957
Portland, OR
Vicompc said:
Ok just got the truck back from the dealer and when pulling into my driveway the truck died. Nothing on, no dash lights, radio etc. I was able to restart it though, any ideas if this could be the switch?
Yet another story of dealer incompetence. Even if it's a no-charge repair, your time and inconvenience is worth something. Unless you have a meter, you can't absolutely confirm it, but the ignition switches have a MASSIVE failure rate and the dealer should have known this. Could also be wiring in the vicinity of the battery, or the front fuse block.

Hope this is a free warranty, and not one of those that get to charge you a diagnostic fee and a deductible even if the diagnosis is wrong.
 

Forum Statistics

Threads
23,388
Posts
638,719
Members
18,596
Latest member
david herman

Members Online