Warning Lights on all at once ???

kenmyfam

Original poster
Member
Dec 11, 2011
168
South West Ontario, Canada
Vehicle as in my signature / description.
The following warning lights came on all at once.
Traction control off (orange light)
Traction control service (orange with the wrench on it)
ABS (orange)
They go on and off intermittently but for the most part they are on solidly.
Seems strange they all arrived at once ???
Any ideas anyone ???
Thanks in advance for any and all info.
Ken.
 

Denali n DOO

Member
May 22, 2012
5,596
harmless said:
Is it throwing a code at least - or just them warning lights?

My stabilitrac service light kept coming on with a 0455 code. The steering position sensor was changed out to solve it. I think I only had 1 light on tho.
 

The_Roadie

Lifetime VIP Donor
Member
Nov 19, 2011
9,957
Portland, OR
Sounds like the classic loose/corroded ground ring lug on the frame rail under the driver's seat. Search and ye shall find.
 

Regulator

Member
Nov 20, 2011
2,496
I would think to check out the wheel speed sensors as well.
 

TollKeeper

Supporting Donor
Member
Dec 3, 2011
8,179
Brighton, CO
Yes, wheel bearing sensor. On these trucks, the ABS sensors for both front wheels is built into the wheel bearing. If either one goes bad, the unit has to be replaced as a assembly.

On a rare occasion you can get to the exciter ring, and pick up magnet, sometimes a good cleaning will also get rid of the codes.
 

Wooluf1952

Member
Nov 20, 2011
2,663
Milwaukee, Wisconsin
Rock Auto has both the ring and sensor as separate parts.
 

TollKeeper

Supporting Donor
Member
Dec 3, 2011
8,179
Brighton, CO
Really? Did not know that..

But isnt it just simply to replace it as a unit?
 

Wooluf1952

Member
Nov 20, 2011
2,663
Milwaukee, Wisconsin
The sensor is a single bolt and less than $50. So if that's the problem, it's easier and cheaper than changing the whole bearing assembly.
 

kenmyfam

Original poster
Member
Dec 11, 2011
168
South West Ontario, Canada
the roadie said:
Sounds like the classic loose/corroded ground ring lug on the frame rail under the driver's seat. Search and ye shall find.

Well, finally got to checking this last Saturday. Found it and removed, cleaned and checked continuity. Good ground but the lights are still on :frown: Guess the sensor checking is next.
 

McGMT

Member
Jun 17, 2012
621
kenmyfam said:
Well, finally got to checking this last Saturday. Found it and removed, cleaned and checked continuity. Good ground but the lights are still on :frown: Guess the sensor checking is next.

Don't forget there are also rear wheel spd sensors... Hardly ever go bad but it would be worth it to check the wires and connections, they sit on the back of the axle tube on either end and I have seen people back up into muck or weed/tree junk and smash them on the tube...
 

Forum Statistics

Threads
23,444
Posts
639,435
Members
18,668
Latest member
Zee0719

Members Online