Vibrations and growling from Underneath!!!!

zamimj222

Original poster
Member
Dec 22, 2011
53
Illinois
Hope someone can help me figure this one out...
I changed the trans fluid and filter along with both diffs and the transfer case. I made sure all the fluids were to their respected full levels. I had used Dexron III instead of Dexron VI so I did flush the whole thing through the trans / radiator tube. I now have a new problem. Around 35 MPH and above there is a growl from underneath that is louder that the engine exhaust. It is accompanied by a slight vibration in the gas pedal. After letting off the gas, it seems to hang up, as if the cruise is on, at the speed for a few seconds before starting to slow. The noise does go away after slowing back down to around 35 MPH.... Any ideas?
 

Wooluf1952

Member
Nov 20, 2011
2,663
Milwaukee, Wisconsin
zamimj222 said:
Hope someone can help me figure this one out...
I changed the trans fluid and filter along with both diffs and the transfer case. I made sure all the fluids were to their respected full levels. I had used Dexron III instead of Dexron VI so I did flush the whole thing through the trans / radiator tube. I now have a new problem. Around 35 MPH and above there is a growl from underneath that is louder that the engine exhaust. It is accompanied by a slight vibration in the gas pedal. After letting off the gas, it seems to hang up, as if the cruise is on, at the speed for a few seconds before starting to slow. The noise does go away after slowing back down to around 35 MPH.... Any ideas?

Check post #5 from your other thread: http://gmtnation.com/f23/transmission-whine-after-servicing-910/#post19502
 

Forum Statistics

Threads
23,225
Posts
637,043
Members
18,381
Latest member
SSLady5

Members Online