Update on the Trailblazer 4200 Vortec

DeltonRushing

Original poster
Member
Apr 19, 2012
33
UPDATE: I just finished cleaning the throttle body and it is running a little better. As soon as I put new oil in it and clean the CPAS it will purr like a kitten! (I hope) I am also going to replace the serpentine belt and spark plugs. I will let you know on the progress, I could have done it without the help of Voymom!!! Thanks!
I have posted picture of the throttle body before and after the cleaning.
I have also posted a video of what it sounds like with the bad CPAS and bad oil.

Here are BEFORE/AFTER pictures of the Throttle Body.

Before Cleaning
View attachment 20739

After Cleaning
View attachment 20740
View attachment 20741

Here is the way it sounds with the bad CPAS and Bad Oil.
[video=youtube_share;vzEKTP-soto]http://youtu.be/vzEKTP-soto[/video]
 

Attachments

  • photo (1).jpg
    photo (1).jpg
    90.5 KB · Views: 20
  • photo (2).jpg
    photo (2).jpg
    65.6 KB · Views: 18
  • photo (3).jpg
    photo (3).jpg
    72.9 KB · Views: 17

Boricua SS

Member
Nov 20, 2011
3,080
Ohio
sounds like you have a cam in it when its in idle :crackup:

hope you get everything fixed :thumbsup:
 

Voymom

Member
Feb 3, 2012
2,523
That's exactly how my Envoy sounded when we put the Engine Restore in ours...well when hubby put it in the truck. I had no part in it as I'd rather use seafoam and smoke out the neighbors :biggrin:
 

03envoy

Member
Dec 25, 2011
537
If only my envoy sounded like that. Without the issues...:yes:
 

Forum Statistics

Threads
23,428
Posts
639,193
Members
18,647
Latest member
Lortigemt

Members Online