Unknown driver

cbmbab97

Original poster
Member
Jun 6, 2013
1
Hi! I have a 2003 Envoy XL. Last night we disconnected the battery and then reconnected this morning at 7am. Wouldn't start and says "unknown driver". Disconnected and reconnected battery. No help. New battery to key FOB, no help. (I have 2, neither one will work)
Tried the online instructions to reprogram key FOB, still not working. Can't start car, operate locks or windows.

Other recent issue, engine stalls immediately when AC tries to come on.
 

dmanns67

Member
Apr 3, 2013
32,979
Ohio
Possibly a bad ignition switch. Do you get any lights at all when you try starting it? I would also say load test your battery and check cables and connects (grounds) before replacing the ignition switch.

Did you happen to unlock your door with the key instead of using the Fob?

Also, it will help if you completely fill out your profile when asking questions about your vehicle.

Welcome to the Nation by the way. :thumbsup:
 

yodaddy4200

Member
Feb 3, 2013
350
cbmbab97 said:
Hi! I have a 2003 Envoy XL. Last night we disconnected the battery and then reconnected this morning at 7am. Wouldn't start and says "unknown driver". Disconnected and reconnected battery. No help. New battery to key FOB, no help. (I have 2, neither one will work)
Tried the online instructions to reprogram key FOB, still not working. Can't start car, operate locks or windows.

Other recent issue, engine stalls immediately when AC tries to come on.


When my fan clutch went out it was doing the same thing... I had REP light (reduced engine power) and check engine light too. It would throw the codes when i hit the A/C.

Dont have a clue about the battery stuff!
 

Wooluf1952

Member
Nov 20, 2011
2,663
Milwaukee, Wisconsin
cbmbab97 said:
Hi! I have a 2003 Envoy XL. Last night we disconnected the battery and then reconnected this morning at 7am. Wouldn't start and says "unknown driver". Disconnected and reconnected battery. No help. New battery to key FOB, no help. (I have 2, neither one will work)
Tried the online instructions to reprogram key FOB, still not working. Can't start car, operate locks or windows.

Other recent issue, engine stalls immediately when AC tries to come on.
This is usually a sign of a dirty throttle body.
http://gmtnation.com/f25/why-you-may-need-clean-4-2l-i6-throttle-body-799/
and
http://gmtnation.com/f25/how-clean-4-2-inline-6-throttle-body-221/

:tiphat: :tiphat: Welcome :tiphat:


In case you haven't heard:
http://gmtnation.com/forums/topic/218-welcome-to-gmtnationcom-heres-the-story/
 

Forum Statistics

Threads
23,400
Posts
638,838
Members
18,614
Latest member
dakis

Members Online