tb stalls when ac is on?

cmatb08

Original poster
Member
Jun 3, 2012
101
so we havent had this issue in awhile. when we are sitting at a stop light and the ac is on the rpms will drop really low and then spike upto about 1k rpms hold there for a lil bit and then die! the only dash light that comes on is the check gauges? we just replaced the fuel pump, the motor mounts will be next we are about 2-300 miles over for a only change we switched back to synthetic and run lucas oil additive, cleaned the air filter about 8k miles ago and the trottle body we clean every oil change. we also just did our first seafoam treatment since the new motor about 20k miles on that. any help would be great thx in advance guys.
 

The_Roadie

Lifetime VIP Donor
Member
Nov 19, 2011
9,957
Portland, OR
It might be a sticky CPAS, assuming you're cleaning the throttle body will the full procedure (remove, clean backside with the battery disconnected, reinstall and drive around a bit for the PCM relearn). If you are just spraying it (as I'm guessing if you do it so often), that's not what we all mean by a TB cleaning.
 

cmatb08

Original poster
Member
Jun 3, 2012
101
no i pull the entire throttle body and the spacer out. ill spray the front and back of the throttle plate and scrub with a toothbrush as well as the spacer. ill do this ever oil change just to make sure its clean some times ill do it every other oil change depending on the amount of time i have. i dont think we had this issue when we moved to north carolina its only out here in az?
 

Forum Statistics

Threads
23,484
Posts
639,854
Members
18,718
Latest member
glennst

Members Online