Stabiltrak light/ 07 trailblazer 4x4 4.2L

jlahood

Original poster
Member
Jan 29, 2012
22
Hello,
First time posting here. Great site.
My stabilitrak light comes on intermittently. It comes on when I first start moving forward. Today had to run to the hardware store. Drove 8 miles to town with no light on. Came out and as soon as I rolled a few feet forward the light came on. If I stop the vehicle and restart it the light will go off.
Sometimes it doesn't come on for days. Other times it will come on a couple times a day, again when I first start to move. What would cause this. I replaced the drivers side hub, lower ball joints and tie rod ends this past fall.
 

jrSS

Member
Dec 4, 2011
3,950
Steering wheel position sensor I believe. Its in the steering column.
 

jlahood

Original poster
Member
Jan 29, 2012
22
Silvernclean,
Thanks for your reply. Is there any kind of write up or pics on it I can check out?
 

Jkust

Member
Dec 4, 2011
946
That particular issue must be on the top 5 list of issues on our 360's that came with stabilitrac. I have seen a full write up with pictures on how to change it yourself but am not sure it made it over to this site.
 

jrSS

Member
Dec 4, 2011
3,950
There are only threads on this sight but no how-to's. I have the same issue but never got it fixed. It doesn't really bother me. U can be the first!! Good luck. Try getting a scan done just to make sure that's the prob. I am for sure it is tho.
 

fletch09

Member
Nov 20, 2011
1,982
silvernclean said:
Steering wheel position sensor I believe. Its in the steering column.

Jkust said:
That particular issue must be on the top 5 list of issues on our 360's that came with stabilitrac. I have seen a full write up with pictures on how to change it yourself but am not sure it made it over to this site.

:iagree:

happened on my 09. everytime i made a certain left turn. (same route to the post office for work everyday)
mine was replaced under warranty.

another thread about the subject:
http://gmtnation.com/f23/service-stabilitrac-light-again-598/
 

deepblue

Member
Dec 5, 2011
56
I'm dealing with that issue too. It came on 3 times in last last 2-3 weeks. I did a little research. The code for the Steering wheel position sensor is C0455. The Stabilitrak/ABS codes are set/stored in the EBCM (electric brake control module), not the PCM. In order to check the code(s), you need scanner capable of reading Stabilitrak/ABS codes. Some of the chain auto parts have this capability and some do not.
I would start by getting the code read and see what you have.
 

Jkust

Member
Dec 4, 2011
946
deepblue said:
I'm dealing with that issue too. It came on 3 times in last last 2-3 weeks. I did a little research. The code for the Steering wheel position sensor is C0455. The Stabilitrak/ABS codes are set/stored in the EBCM (electric brake control module), not the PCM. In order to check the code(s), you need scanner capable of reading Stabilitrak/ABS codes. Some of the chain auto parts have this capability and some do not.
I would start by getting the code read and see what you have.

Or just press your Onstar button and find out in 30 seconds while you are driving.
 

Forum Statistics

Threads
23,442
Posts
639,384
Members
18,664
Latest member
SooMenn22

Members Online