Squeaking Upper Control Arm Bushings

ronald_968

Original poster
Member
Mar 29, 2012
5
At 185k miles I changed out the shocks and upper control arm bushings. The new upper control arm bushings are now making a squeaking noise when I brake. Did I do something wrong or are they defective or is this temporary? BTW the upper control arm bushings are Moog.
 

Sparky

Member
Dec 4, 2011
12,927
Sure it is the upper bushings? When you replaced the shocks did you replace the upper mounts on the front also?
 

seanpooh

Member
Jan 24, 2012
461
Also when you tighten those two bolts on the UCA, it would of helped if you loaded the arm first with the jack then tighten the two bolts. The squeaking will eventually go away after break in I believe.
 

ronald_968

Original poster
Member
Mar 29, 2012
5
Sparky
Sure it is the upper bushings? When you replaced the shocks did you replace the upper mounts on the front also?

Yes. I bought two new shock mounts when replacing the shocks.

seanpooh
Also when you tighten those two bolts on the UCA, it would of helped if you loaded the arm first with the jack then tighten the two bolts. The squeaking will eventually go away after break in I believe.

I didn't try loading the arm with a jack when I tightened the bolts. I might loosen the bolts and load the arm first with the jack and re-tighten the bolts. They don't squeak on every bump, only when I brake or when the front dips more than usual.
 

Sparky

Member
Dec 4, 2011
12,927
OK the upper mounts sometimes can be the cause of squeaks if they are worn which is why I asked.

I would try retightening the bolts with the suspension loaded. It is always a good idea to do that with suspension parts so that the bushings are in the most neutral position when the vehicle is on its wheels instead of preloaded. They'll also last longer. So give that a shot and let us know if the squeak goes away :thumbsup:
 

Forum Statistics

Threads
23,229
Posts
637,063
Members
18,390
Latest member
jgriff

Members Online