Something in AC squeaking.

wesman43

Original poster
Member
Apr 30, 2013
199
I have a loud squeak coming from something in the engine pertaining to AC. It happens every other time I upshift or go from 1200 to 2000 rpm and back. Its just a really loud SQEAUK!!!!!!! Once then everything is back to normal. I changed the belt thinking this was the problem but nope.

However, When I turn the blower/AC off completely I can't reproduce the noise at all anymore. Which pretty much stumps me lol
 

jimmyjam

Member
Nov 18, 2011
1,634
It's the ac clutch. Either gapped too far or there is dirt and junk in it causing slippage. What you are hearing is it slipping. Usually will happen when trying to engage at higher rpms. A search for ac clutch should render useful information
 

wesman43

Original poster
Member
Apr 30, 2013
199
jimmyjam said:
It's the ac clutch. Either gapped too far or there is dirt and junk in it causing slippage. What you are hearing is it slipping. Usually will happen when trying to engage at higher rpms. A search for ac clutch should render useful information

Danke :smile:
 

wesman43

Original poster
Member
Apr 30, 2013
199
Okay, I did quite a thorough search, and it seems to me that it may be slipping as you said. However, usually with this issue there are more problems like the air not being cold etc. It looks like a pretty simple fix of shimming it, but i'll give you a definitive answer tomorrow when I'm not at work and have time to look at it to see if it slips at higher RPMs.

Also, if I can pinpoint the squeak to the AC pulley area then might as well do something about it even though it's working fine xD
 

Forum Statistics

Threads
23,473
Posts
639,777
Members
18,703
Latest member
ckazacos

Members Online