rattling noise

jrthomas05

Original poster
Member
Aug 20, 2012
25
lately ive noticed a rattle going from the engine compartment. once its warmed up and i drive probably 10-20 miles i get a rattle between 2000-3000 rpms. today i put it in park and around 2000 rpms it was also doing it. i havent had time to poke around yet. just wondering if this has happened to anyone else. possibly in the exhaust im thinking.
 

Wooluf1952

Member
Nov 20, 2011
2,663
Milwaukee, Wisconsin
Since you can make it happen while in PARK, get a helper to listen outside the truck while you rev the engine. Or you listen while your helper revs it.

Also, did you mean to type Rattling Noise, for the title?
 

WarGawd

Member
Sep 2, 2012
468
jrthomas05 said:
lately ive noticed a rattle going from the engine compartment. once its warmed up and i drive probably 10-20 miles i get a rattle between 2000-3000 rpms. today i put it in park and around 2000 rpms it was also doing it. i havent had time to poke around yet. just wondering if this has happened to anyone else. possibly in the exhaust im thinking.

A quick and easy process that might help narrow down the source is to use a 3/8" breaker bar or ratchet on the tensioner pulley assembly, remove the belt, and run the engine briefly without all the accessories to see if it changes/goes away.

{FYI when I did this myself, I got a CEL after re-installing the belt, presumably because the alternator wasn't charging for a bit (may have been other causes too, IE commanded fan speed not matching actual - I just didn't have a scan tool handy, and really wasn't concerned enough to bother checking)...cleared itself after a couple ignition cycles}

Also consider taking a quick video clip before and after to post because one man's rattle is another man's rumble...hearing the noise may trigger someone's memory of what the problem was when their vehicle made that noise. On limited evidence and description I'll take a WAG and suggest exhaust manifod heat shield.
 

jrthomas05

Original poster
Member
Aug 20, 2012
25
im pretty sure its the ac compressor. yesterday was the first day its been cool enough to drive around with the windows dog. also seemed like w/o the ac on had significantly more power. cleaned my throttle body less then 1 k ago also. anyone else experience issues with the ac compressor
 

Forum Statistics

Threads
23,307
Posts
637,746
Members
18,509
Latest member
Napalm

Members Online