Radio doesn't turn off after key is pulled out

hrddrv

Original poster
Member
Dec 4, 2011
120
Radio doesn't turn off after key is pulled out. Stock Bose radio. It does turn off after about 2 minutes. Also the light on the door for the window lock stays on for about the same amount of time. No other lights stay on. Do I need a new ignition switch or is it possibly something else?
 

24v 4.2

Member
Jan 16, 2013
430
If it turns off when you open the door, I believe that is normal. My bose system will stay on until I open the door.
 

Boricua SS

Member
Nov 20, 2011
3,080
Ohio
do your windows still work while the truck is turned off too? you didnt specify if the door is opened when all of this is going on... if the door is closed and you turn off the truck, then your RAP's (Retained Accessories Power) kick in, and until a door opens, the radio and windows will still function... this is normal...

if after you turn the truck off, and you open the door, things still stay on, then its a deeper issue...
 

CaptainXL

Member
Dec 4, 2011
2,445
hrddrv said:
Radio doesn't turn off after key is pulled out. Stock Bose radio. It does turn off after about 2 minutes. Also the light on the door for the window lock stays on for about the same amount of time. No other lights stay on. Do I need a new ignition switch or is it possibly something else?

Sounds like you need to see if the door locks are working right. The door switch is part of it. There are no door pins. These can easily be tested if the dome light goes out shortly after closing door and locking with the fob.
 

hrddrv

Original poster
Member
Dec 4, 2011
120
Boricua SS said:
do your windows still work while the truck is turned off too? you didnt specify if the door is opened when all of this is going on... if the door is closed and you turn off the truck, then your RAP's (Retained Accessories Power) kick in, and until a door opens, the radio and windows will still function... this is normal...

if after you turn the truck off, and you open the door, things still stay on, then its a deeper issue...

Yes the windows work. The door is open. And yes the dome lights go out shortly after the door is shut and locked with remote. Everything does shut off a few minutes later but this is not what used to happen. If I turned off the car pulled my key out and opened the door the radio would shut off.
 

CaptainXL

Member
Dec 4, 2011
2,445
hrddrv said:
Yes the windows work. The door is open. And yes the dome lights go out shortly after the door is shut and locked with remote. Everything does shut off a few minutes later but this is not what used to happen. If I turned off the car pulled my key out and opened the door the radio would shut off.

Try exiting out the passenger side. Same experience? I'm thinking your door switch is staying locked but not the lock itself. Could be wiring or shorted switch. Something along those lines.
 

24v 4.2

Member
Jan 16, 2013
430
hrddrv said:
Yes the windows work. The door is open. And yes the dome lights go out shortly after the door is shut and locked with remote. Everything does shut off a few minutes later but this is not what used to happen. If I turned off the car pulled my key out and opened the door the radio would shut off.

Ok, maybe it is the sensor for the door? Try it (turn off key and then open pass door) from the passenger seat with the driver door closed.
 

CaptainXL

Member
Dec 4, 2011
2,445
24v 4.2 said:
Ok, maybe it is the sensor for the door? Try it (turn off key and then open pass door) from the passenger seat with the driver door closed.

Beat ya. Muhahah..!
 

24v 4.2

Member
Jan 16, 2013
430
CaptainXL said:
Beat ya. Muhahah..!

Saw that...:frown:
Though in all fairness, we were probably typing it at the same time. :thumbsup:
 

hrddrv

Original poster
Member
Dec 4, 2011
120
CaptainXL said:
Try exiting out the passenger side. Same experience? I'm thinking your door switch is staying locked but not the lock itself. Could be wiring or shorted switch. Something along those lines.
I will try it in the morning.
 

hrddrv

Original poster
Member
Dec 4, 2011
120
OK kind of. everything is working correctly now. What I did, and am not sure if this is what did it or not, I slammed all 5 doors really hard. After that everything worked the way it should.
 

CaptainXL

Member
Dec 4, 2011
2,445
hrddrv said:
OK kind of. everything is working correctly now. What I did, and am not sure if this is what did it or not, I slammed all 5 doors really hard. After that everything worked the way it should.

Sounds good, but dont get confident just yet. You still got a problem more than likely. Could be that your locks need lube or the door strikers need adjusting. Or even a failing switch.
 

hrddrv

Original poster
Member
Dec 4, 2011
120
CaptainXL said:
Sounds good, but dont get confident just yet. You still got a problem more than likely. Could be that your locks need lube or the door strikers need adjusting. Or even a failing switch.

True but it works for now. I will keep an eye on it. I do plan on lubing everything up tomorrow though.
 

tjmoffa

Member
Apr 4, 2013
12
Just picked up my TB today, yay!! Only issue is the driver side door does not shut off the radio or activate the interior lights, all other doors work as they should. Is there a simple contact switch to replace? Thanks in advance.
 

Tmn8tr

Member
Jan 22, 2013
12
hrddrv said:
Yes the windows work. The door is open. And yes the dome lights go out shortly after the door is shut and locked with remote. Everything does shut off a few minutes later but this is not what used to happen. If I turned off the car pulled my key out and opened the door the radio would shut off.

Mine has been doing this too, intermittently. I didn't notice that it was doing it until it did it at night, and the headlights wouldn't turn off. I did notice a funny yellow light on the dash that looks like a truck parked behind a big lock. When this is on it acts the way you have described.
>T
 

kjkim93

Member
Jan 1, 2012
696
Tmn8tr said:
Mine has been doing this too, intermittently. I didn't notice that it was doing it until it did it at night, and the headlights wouldn't turn off. I did notice a funny yellow light on the dash that looks like a truck parked behind a big lock. When this is on it acts the way you have described.
>T

That symbol is just the factory security system being activated
 

RayVoy

Member
Nov 20, 2011
939
tjmoffa said:
Just picked up my TB today, yay!! Only issue is the driver side door does not shut off the radio or activate the interior lights, all other doors work as they should. Is there a simple contact switch to replace? Thanks in advance.
It is probably the switch inside the door that signals the door is open.

It is mounted on the door lock/unlock mech behind the outside handle.

I don't remember if it is a serviceable part, or if the lock/unlock mech needs to be replaced.
 

tjmoffa

Member
Apr 4, 2013
12
RayVoy said:
It is probably the switch inside the door that signals the door is open.

It is mounted on the door lock/unlock mech behind the outside handle.

I don't remember if it is a serviceable part, or if the lock/unlock mech needs to be replaced.

Thanks!!!! almost ordered a ddm!
 

tjmoffa

Member
Apr 4, 2013
12
I called my local dealership and they quoted me $198.10 for the factory replacement automatic door lock acuator that includes the door ajar sensor. I need to find out if I have the antitheft option, I guess it makes a difference. Does anyone know if I could use an actuator that does not have the anti-theft if I indeed have that option, or would I have to get one that would be a direct replacement?
 

CaptainXL

Member
Dec 4, 2011
2,445
Skip the dealer. A door lock actuator is only about $25 at local parts stores. Just go to Advance Auto and have the desk look it up. I would take the actuator out first though and make sure it works and it's not just the locking mechanism bound up.
 

tjmoffa

Member
Apr 4, 2013
12
CaptainXL said:
Skip the dealer. A door lock actuator is only about $25 at local parts stores. Just go to Advance Auto and have the desk look it up. I would take the actuator out first though and make sure it works and it's not just the locking mechanism bound up.

Great, thanks. The lock mech works by button and remote, but the dic does not sense the door is open, hence my trouble. I looked up the part at rock auto and advance auto and they both list parts that are and are not anti-theft compatible, but if the cheap one works, hell yeah!
 

RayVoy

Member
Nov 20, 2011
939
tjmoffa said:
I need to find out if I have the antitheft option,
Check the list of build codes (RPO, Regular Production Order) on the glove box door. UA6 is the code for ant-theft. No UA6, no anti-theft.
 

tjmoffa

Member
Apr 4, 2013
12
View attachment 27359
RayVoy said:
Check the list of build codes (RPO, Regular Production Order) on the glove box door. UA6 is the code for ant-theft. No UA6, no anti-theft.

Awesome, thx! There it is! Rats. Thanks again, I guess i am yard hopping this weekend, the anti theft units are spensive.
 

Attachments

  • photo.JPG
    photo.JPG
    26.4 KB · Views: 61

RayVoy

Member
Nov 20, 2011
939
The module is probably working fine, there is probably a faulty sensor.
 

tjmoffa

Member
Apr 4, 2013
12
RayVoy said:
The module is probably working fine, there is probably a faulty sensor.

I hit the yards in my area and only found one donor but the window was gone so I didn't waste my time. Dealer said the sensor was actually in the lock acuator mechanism and not replaceable seperately. I havn't taken my door apart yet but I wasn't sure if there some way to clean something or possibly lubricate a mechanism for the sensor "magically" spring back to life? Thx for the help.
 

CaptainXL

Member
Dec 4, 2011
2,445
tjmoffa said:
I havn't taken my door apart yet but I wasn't sure if there some way to clean something or possibly lubricate a mechanism for the sensor "magically" spring back to life? Thx for the help.

Yes, that's why I said take it out and inspect first.
 

tjmoffa

Member
Apr 4, 2013
12
CaptainXL said:
Yes, that's why I said take it out and inspect first.

Finally got to it, cleaning didn't work, but I pulled the mech from the rear door and swapped em, good for now, thx for all the help.:smile:
 

Forum Statistics

Threads
23,307
Posts
637,746
Members
18,509
Latest member
Napalm

Members Online