P0128 (reposted from the other site)

MAY03LT

Original poster
Member
Nov 18, 2011
3,422
Delmarva
This happened back in August of 2011, reposting it here to build up the archives.

Coming home from Carlisle, the gauge was 2 ticks left of center.

fc0aa4ef.jpg


No check engine light. A look into the DTC list revealed the P0128.

f4b8af4c.jpg


I watched the engine temp as it got to 180 degrees or so and stayed there.

06ec6baf.jpg


After verifying that the coolant level was ok, I swapped out the thermostat.

5085c27f.jpg


Temp gauge back to "normal".

a6b237af.jpg


I kinda goofed here, I didn't take a pic with a shorter run time. It got up to 205-ish in a few minutes.

39fcc1b0.jpg


And there you have it. During the three or four days it took me to get the time to fix my own TB, I documented a 6mpg loss. Moral of the story - if you have a P0128, fix it!
 

fishguy1123

Member
Dec 5, 2011
310
Can you please move to MI.????? That would be great! Thanks, sincerely 360 owners that live in MI.!!!! :yes:
 

Mark20

Member
Dec 6, 2011
1,630
That 181F was about what I was seeing on my Scan Gauge when my T-Stat or temperature sensor went.
 

MichEnvoyGuy

Member
Dec 3, 2011
522
I just wanted to add my piece. I dont know if its my truck or not, but Ive never run at anything above 195*f. I just replaced my t-stat (2nd time) & original ECT 2 months ago and the highest I get is 195* and only when Im stopped at a red light. Once I start driving it settles at 190*. :undecided:

Edit: The temperatures are live temps taken from the ECT and read on my Equus 3130.
 

JPZ

Member
Dec 4, 2011
34
Thermostat getting changed tomorrow. Mine is running a little cool with a CEL on.
 

Forum Statistics

Threads
23,388
Posts
638,719
Members
18,596
Latest member
david herman

Members Online