HID Color Fade/Flicker

DenaliHD66

Original poster
Member
Dec 4, 2011
597
Left front low beam is a set of 8000k hids. This one seems to flicker alot, like its bouncing in its housing, but I think its just slowly dying out. I also noticed its the color of the standard halogens now, and lost its blue tint. Works for the most part, but was wondering if it is just the bulb going bad? Would be hard pressed to think its actually vibrating around in its socket like it seems at times.
 

Blckshdw

Moderator
Nov 20, 2011
10,706
Tampa Bay Area, FL
Swap the bulb (or ballast) with the one from the other side, and that should give you a more definitive idea of where the problem is (bulb vs ballast). I'm putting my money on the bulb going bad, due to the color shift. Bulbs are relatively cheap, so replacing it wouldn't break the bank. :twocents:
 

ItsOnVoy

Member
Nov 21, 2011
2,401
Are you running DRL's on your HID's? Because the DRL's will kill the life of your HID's really quick and does cause flicker...If not then you might have a lemon for your ballast and need to replace it or the bulb is just going bad.
 

DenaliHD66

Original poster
Member
Dec 4, 2011
597
Forget the brand, I wanna say they are German something technology or something. Yes I do have DRL with them, and I usually turn them off if its bright outside, but they still "turn on" for a second as I'm starting up until I can use the headlight switch to turn them off. I guess it would be wise to disable DRL in the future. All in all, they've been in for 2 years and just now starting to go bad. I've heard of others burning out within a couple weeks with DRL still enabled.

Pretty sure these are the ones I bought from carhidkits.com.
 

Blckshdw

Moderator
Nov 20, 2011
10,706
Tampa Bay Area, FL
DenaliHD66 said:
Forget the brand, I wanna say they are German something technology or something. Yes I do have DRL with them, and I usually turn them off if its bright outside, but they still "turn on" for a second as I'm starting up until I can use the headlight switch to turn them off. I guess it would be wise to disable DRL in the future. All in all, they've been in for 2 years and just now starting to go bad. I've heard of others burning out within a couple weeks with DRL still enabled.

Pretty sure these are the ones I bought from carhidkits.com.

Makes me all the more suspicious of the bulb going bad. Confirm with a bulb swap with the other side. :yes:
 

ItsOnVoy

Member
Nov 21, 2011
2,401
Blckshdw said:
Makes me all the more suspicious of the bulb going bad. Confirm with a bulb swap with the other side. :yes:

:iagree:Yeah I would try the bulb and if it isnt that, has to be the ballast. I recommend DDMtuning or VVME kit. Many of us GMT owners have those and great lights and I have DDM myself and work great! Good luck :thumbsup:
 

Boricua SS

Member
Nov 20, 2011
3,080
Ohio
yup +3 on a bad bulb...

as carlton mentioned.. i'd switch bulbs to see if the problem follows the bulb...
 

Forum Statistics

Threads
23,484
Posts
639,853
Members
18,717
Latest member
Leoliboy

Members Online