Heated Seats and Memory Position - New Drivers door module, Or...?

Black-n-Yellow

Original poster
Member
May 22, 2013
10
My drivers side heated seats are not functioning and NEITHER is the memory 1 or 2 buttons. With summer upon us I am less concerned about the heated seats; however, I recently had the pleasure of rebuilding my stupid kelsey hayes EBCM, in which I had the battery disconnected long enough that it seemed to forget my settings for driver 1.
I am now extremely annoyed as every time I get in the car now, I have to completely readjust the passenger side view mirror in order to see anything at all. So of course I put the seat and mirrors where I want them and hold the driver 1 button down awaiting it to store the positions, and nothing. So apparently that function on the drivers door module isn't working either- not just the heated seat.

Before I spring for a new drivers door module--- I wanted to check with the great minds here to see if it could possibly be something other than the switch unit itself or if I could possibly fix my current switch instead of having to buy a replacement.

BTW- all other buttons work correctly, windows, locks, window-lockout... and the heated seats work fine on the passenger side.

Thanks in advance!
 

Phantom

Member
Jun 17, 2012
277
Have you tried taking the DDM out and seeing if the connection was good? I know in my wifes envoy, the plug to the memory seats has a bad connection because there is a little bracket that is broken that holds the door handle together tightly. Here is the link to her thread. http://http://gmtnation.com/f23/drivers-door-module-memory-seats-3566/
It doesnt show the bracket itself but this for sale thread has them for sale and shows a picture of where they are.http://gmtnation.com/f106/door-brackets-retainers-02-04-envoy-7405/

Hopefully this helps.
 

Black-n-Yellow

Original poster
Member
May 22, 2013
10
Phantom said:
Have you tried taking the DDM out and seeing if the connection was good? I know in my wifes envoy, the plug to the memory seats has a bad connection because there is a little bracket that is broken that holds the door handle together tightly. Here is the link to her thread. http://http://gmtnation.com/f23/drivers-door-module-memory-seats-3566/
It doesnt show the bracket itself but this for sale thread has them for sale and shows a picture of where they are.http://gmtnation.com/f106/door-brackets-retainers-02-04-envoy-7405/

Hopefully this helps.

Thanks phantom....
Learned a little bit this morning... pulled the whole switch module--- I plugged in the passenger module to the drivers side and discovered that the heated seats do work on the drivers side so I know my problem is in the switch itself.
All of my wiring looks fine.
I also pulled the small module from underneath the switch assembley that has the driver 1,2 memory buttons and upon inspection I felt it necessary to open that little guy up and check inside of it, only to discover the circuit board inside is totally corroded. It has its own part number (15180651) so I could get away with just replacing that part of the module instead of the whole switch module IF my problem were just with the memory functions... The heated seats part appears to be part of the main module itself which is a bummer because I don't seem to be having any luck coming across one in a scrap yard locally, and can't afford to buy the whole module on ebay right now going for $85-189... my budget only allows for about $50 to replace that whole drivers door module.
 

Forum Statistics

Threads
23,392
Posts
638,779
Members
18,601
Latest member
Chris Moore

Members Online