Got the scratch..scratch.. sound!

fishguy1123

Original poster
Member
Dec 5, 2011
310
I think my hvac actuator is failing. I get a repeated scratching sound from the dash (driver side) when I have the upper vents on. A/C or heat, only when the dash vents are on. I have the auto hvac system and wanted to see if anyone can tell me either way. The vents still work, just sounds like a mouse is trying to get out... :crazy: Thanks!
 

Voymom

Member
Feb 3, 2012
2,523
fishguy1123 said:
I think my hvac actuator is failing. I get a repeated scratching sound from the dash (driver side) when I have the upper vents on. A/C or heat, only when the dash vents are on. I have the auto hvac system and wanted to see if anyone can tell me either way. The vents still work, just sounds like a mouse is trying to get out... :crazy: Thanks!


Join the party!! I think my rear actuator is taking a croak on me too.

I now realize WHY the original owners traded this truck in as soon as they could lol
 

fishguy1123

Original poster
Member
Dec 5, 2011
310
They knew how much YOU would love to have him... lol I think I helped mine along when I cleaned my tb. I forgot to turn off the hvac when I disconnected the batterie. Just pulled the 10 and 30 amp fuses but no luck.
 

tbuckalew14

Member
Nov 20, 2011
380
Mine makes the sound for a good half mile - mile before finally stopping. I keep meaning to get that fixed. Been doing it for a long time. Some time the vents don't work..recently they have been. It's on the very bottom of my to fix list though.
 

fishguy1123

Original poster
Member
Dec 5, 2011
310
Honestly, since the vents..heat/ac have been working I've just turned the radio up a lil bit. :yes: Just want to make sure I'm looking to replace the right part when I do.
 

Voymom

Member
Feb 3, 2012
2,523
fishguy1123 said:
They knew how much YOU would love to have him... lol I think I helped mine along when I cleaned my tb. I forgot to turn off the hvac when I disconnected the batterie. Just pulled the 10 and 30 amp fuses but no luck.

Yeah, I still think it was a setup lol. I think we helped ours out when hubby and I changed the water pump. We disconnected the battery without turning the HVAC off as well. Hubby is thin skinned and has the heat on in the truck when it's in it's 60's/70's lol. But it didn't give us any issues until last night, and it's been a week and a half almost 2 weeks since we changed the water pump. So it may be entirely unrelated.

If I didn't have so many kids I'd trade him in for an SS :lipsrsealed:
 

Voymom

Member
Feb 3, 2012
2,523
fishguy1123 said:
With your right foot you better buy stock in a tire manufacturer first! :rotfl:

That and I should probably try and make friends with the local police and sheriff's :biggrin:

I think the DMV would void my drivers license the moment they found out I got something with more ponies. :redface:
 

Wooluf1952

Member
Nov 20, 2011
2,663
Milwaukee, Wisconsin
fishguy1123 said:
Honestly, since the vents..heat/ac have been working I've just turned the radio up a lil bit. :yes: Just want to make sure I'm looking to replace the right part when I do.

That's how I'm currently dealing with my whiny alternator. :wootwoot:
 

Sparky

Member
Dec 4, 2011
12,927
Wooluf1952 said:
That's how I'm currently dealing with my whiny alternator. :wootwoot:

I tried doing that with my AC pulley bearing, but then my stupid aftermarket radio harness decides to cut out and shut off the radio :hissyfit:
 

Forum Statistics

Threads
23,488
Posts
639,901
Members
18,722
Latest member
Mmc0229

Members Online