finally got the vibration gone ...... i hope

nbenjamin

Original poster
Member
Dec 7, 2011
76
So after about almost a year of the vibrating and trying to figure it out , i said screw it and changed the water pump . smooth as glass now . I'm pissed because when it started last year the first thing i did was change the water pump . the pump i put in was bad . it had a wobble but was stiff enough that was not noticeable .

i am curious now , should i change my thermostat and temp sensor ?? 05 with 167000 , god knows i have done everything else to .
 

The_Roadie

Lifetime VIP Donor
Member
Nov 19, 2011
9,957
Portland, OR
Only if you get the dreaded P0128 code or the temp gauge isn't solidly on 210.
 

CaptainXL

Member
Dec 4, 2011
2,445
nbenjamin said:
So after about almost a year of the vibrating and trying to figure it out , i said screw it and changed the water pump . smooth as glass now . I'm pissed because when it started last year the first thing i did was change the water pump . the pump i put in was bad . it had a wobble but was stiff enough that was not noticeable .

i am curious now , should i change my thermostat and temp sensor ?? 05 with 167000 , god knows i have done everything else to .

I can see where Roadie is coming from but in this case it probably wouldn't have been such a bad idea. Since you replaced the coolant after changing the pump you will need to do it again with a T-stat change. To do these separately would require a rehash of draining the coolant.
 

Forum Statistics

Threads
23,330
Posts
637,990
Members
18,534
Latest member
06_4.2_4x4_ls