Envoy acting weird

warriorpluto

Original poster
Member
Apr 12, 2012
215
First my battery died then I had to get a new battery. Probably killed from jumping folks off all the time. Ok now when I hook up the new battery my actuators no longer work. I don't even.get AC anymore. The passenger side temp control is no longer lit. Only get air through rear vents and through dash vent and floor. When air is on at idle i can hear the AC compressor constantly click every ten seconds and the truck almost shuts off but catches itself. I can no.longer spin my tires from a take off. Low on power. Spark plugs were changed 10k miles ago with AC delco.
 

warriorpluto

Original poster
Member
Apr 12, 2012
215
Envoy is 03 here's a picture of temperature control
 

Attachments

  • uploadfromtaptalk1367982900819.jpg
    uploadfromtaptalk1367982900819.jpg
    22.6 KB · Views: 3

Ryda55555

Member
Apr 11, 2013
1,111
warriorpluto said:
First my battery died then I had to get a new battery. Probably killed from jumping folks off all the time. Ok now when I hook up the new battery my actuators no longer work. I don't even.get AC anymore. The passenger side temp control is no longer lit. Only get air through rear vents and through dash vent and floor. When air is on at idle i can't hear the AC compressor constantly click every ten seconds and the truck almost shuts off but catches itself. I can no.longer spin my tires from a take off. Low on power. Spark plugs were changed 10k miles ago with AC delco.

I dont know whats wrong but just a tip for the future.
When you boost people put the positive on the battery terminal and not the fuse box and put the negative on a ground and not the negative of the battery
(Maybe you boosted with the positive on the fuse box and it blew fuses or fried the motherboard?)
I hope its a simple fix
 

Wooluf1952

Member
Nov 20, 2011
2,663
Milwaukee, Wisconsin
warriorpluto said:
First my battery died then I had to get a new battery. Probably killed from jumping folks off all the time. Ok now when I hook up the new battery my actuators no longer work. I don't even.get AC anymore. The passenger side temp control is no longer lit. Only get air through rear vents and through dash vent and floor. When air is on at idle i can hear the AC compressor constantly click every ten seconds and the truck almost shuts off but catches itself. I can no.longer spin my tires from a take off. Low on power. Spark plugs were changed 10k miles ago with AC delco.


You don't have any info about your ride, but if it's the 4.2 I6, you probably need to clean the throttle body to start.

http://gmtnation.com/f25/why-you-may-need-clean-4-2l-i6-throttle-body-799/

http://gmtnation.com/content/how-clean-4-2-i6-throttle-body-120/
 

CaptainXL

Member
Dec 4, 2011
2,445
warriorpluto said:
Envoy is 03 here's a picture of temperature control

Lights burning out is just a symptom of old age. I replaced my HVAC head unit with burnt out bulbs just as you show.

What you got here is more than likely a combination of failing stuff and blown fuses. It's likely just a coincidence.

Just repair each thing in turn starting with the most serious/urgent.
 

warriorpluto

Original poster
Member
Apr 12, 2012
215
CaptainXL said:
Lights burning out is just a symptom of old age. I replaced my HVAC head unit with burnt out bulbs just as you show.

What you got here is more than likely a combination of failing stuff and blown fuses. It's likely just a coincidence.

Just repair each thing in turn starting with the most serious/urgent.

Thanks guys for.the.responses. I'll.clean the throttle body tomorrow evening. But shoot man I need my air. I have two baby boys. I'll look over that thread for the actuators. Thanks again guys. Oh yea and how do I change the bulb?
 

Ryda55555

Member
Apr 11, 2013
1,111
warriorpluto said:
Thanks guys for.the.responses. I'll.clean the throttle body tomorrow evening. But shoot man I need my air. I have two baby boys. I'll look over that thread for the actuators. Thanks again guys. Oh yea and how do I change the bulb?

Cleaning the throttle body makes a world of difference if thats the problem, simple fix and doesnt take too long at all
As for the bulb its a pretty difficult task

Climate Control Light Bulb Fix - How To - Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum

But good luck i hope everything goes smooth for you
 

CaptainXL

Member
Dec 4, 2011
2,445
Multiple actuators failing at the same time is suspicious. In this case the hvac head unit is suspect right out the gate.
 

warriorpluto

Original poster
Member
Apr 12, 2012
215
CaptainXL said:
Multiple actuators failing at the same time is suspicious. In this case the hvac head unit is suspect right out the gate.

Luckily the junkyard has two trail blazers out there I'll pull those and see of there is any change
 

Forum Statistics

Threads
23,234
Posts
637,113
Members
18,398
Latest member
DR.B

Members Online