Cruise turning off by itself

nbenjamin

Original poster
Member
Dec 7, 2011
76
I noticed my cruise turns off by itself sometimes . usually around 120 km/hr , any ideas ??

when it happens if i turn it back it keeps turning off , then i get pissed and leave it off till next time driving .
 

The_Roadie

Lifetime VIP Donor
Member
Nov 19, 2011
9,957
Portland, OR
Do you have a SES light on? Or intermittently flashing? Many drivetrain (engine and tranny) codes will suppress cruise control operation. Or as previous threads on the same subject have discussed, a hair-trigger brake switch or dirty multifunction switch can do it.

But rather than shotgun and throw parts at the problem, the GM designers did one clever thing. They retain in PCM memory a list of the last few reasons that CC was turned off, whether it was by a brake light, SES code, or the switch. Get a dealer or somebody with a high end scan tool to look at that memory section and you will know for sure what to look at and fix next. Admittedly some dealers overcharge for this simple service, so call around.
 

nbenjamin

Original poster
Member
Dec 7, 2011
76
No ses lights on. I do noticed a slight squeal from my rear passenger wheel. Brake pads were replaced last year but didn't touch the drum which I heard is for hand brake . Would that maybe contribute ? I will try get the PCM memory read also.
Then maybe drive the truck off a cliff.
 

Voymom

Member
Feb 3, 2012
2,523
I'll give him $500.00 cash for it right now!! :biggrin:
 

kardain

Member
Dec 16, 2011
557
Voymom said:
I'll give him $500.00 cash for it right now!! :biggrin:

$501 and a multi-pack of tasty beverage :smile:
 

Sparky

Member
Dec 4, 2011
12,927
600! :rotfl:
 

nbenjamin

Original poster
Member
Dec 7, 2011
76
Such high offers lol that should be an indication of just what our trucks are worth.
I would feel to guilty selling it lol.
After all GM runs so deep........ In my pocket !
 

Voymom

Member
Feb 3, 2012
2,523

seanpooh

Member
Jan 24, 2012
461
My cruise also did the same, just turning off by itself with no SES light or anything. It happened on two occasions for a few days.

The first time was after changing my tie rod ends and sway bar link. I know, no relations but still. It kept going off after I put it on for a few days and then worked fine.

Then the other occasion was this year. It happened when BestBuy installed my Viper system. It came off after two times then went back to normal.

I guess it just happens and it should operate back to normal after a while. You could disconnect the battery so that the PCM can reset. Doesn't hurt. Or lightly move cables around inside the hood.

I did hear that cruise control has a computer by itself but I'm not sure that it's definite though.
 

navigator

Member
Dec 3, 2011
504
occasionally my cruise won't come set.
the odd thing about mine is it is always towing my boat on the way home from fishing.
The cruise will work going to wherever we are going but for some reason it won't work on the way home towing the boat.
Very odd. I've never worried about it because I don't live but about 20 mins from where I usually fish.
 

Wyle

Member
Dec 4, 2011
200
navigator said:
occasionally my cruise won't come set.
the odd thing about mine is it is always towing my boat on the way home from fishing.
The cruise will work going to wherever we are going but for some reason it won't work on the way home towing the boat.

TB refuses to cooperate when returning from fishing trips?! Hmmm. Sounds like a worthwhile mod to me. :thumbsup:
 

Forum Statistics

Threads
23,428
Posts
639,196
Members
18,647
Latest member
Lortigemt

Members Online