4x4 selector switch

rjpoog1989

Well-Known Member
Today I was messing around with my 4x4 switch. I didn't really need 4 wheel drive but put it in just in case. I could hear the actuator clicking but the light on the 4 high button kept flashing. Same thing with 4 low I could hear and feel it engage but the light never stopped flashing. No service 4x4 light on the dash or anything like that. I don't think that this was the case 2 weeks ago when I last used 4 wheel but I don't know that for certain. The only thing I didn't try was putting the transfer case in neutral to see what that would do.

Thanks in advance,
Ryan
 
OP
OP
rjpoog1989

rjpoog1989

Well-Known Member
After much confusion and searching other forums and talking to anybody and everybody that knows about cars I thought I solved this problem. I replace the actuator on the front differential about 3 weeks ago. 4x4 was working perfectly until a few days ago I went to engage and all I got was flashing lights once more. I had a load of stuff to take to my back yard and couldn't get up there without 4x4 so it really pissed me off. The next day I tried to engage 4x4 and everything worked fine. I've been trying it every day since and it has worked fine. This is pissing me off:hissyfit: I bought a railroad tie this morning and cut it in half and put that in the bed, hopefully that will allow me enough traction to make it if 4x4 fails me when I need it (I live in PA and we're getting snow like tomorrow!).
 

tblazerdude

Well-Known Member
Sounds like your actuator is struggling. (the part you just replaced) Even the new one (you're old one was probably fine, and the new one works a little better, but thats not the problem) If the actuator is flashing your 4WD lights and not fully engaging it may mean it is obstructed, when pushing the shift fork collar onto the spindle in order to connect drive shafts. This all happens in the passenger side 4WD disconnect. If you caught it in time, you can remove the unit (actually you could essentially re-grease with half of it attached to the oil pan, IIRC) and re-grease. This has become one of the major flaws of the gmt360 platform, where either damaged components or lack of good grease destroys the "splined disconnect" Do you commonly drive around in A4WD? What mileage are you at? Did you service the transfer case at 50k?
 

mika

Well-Known Member
Could be just the selector switch its self, has it ever change to 4hi with you touching the switch? or when you go to select 4hi or low it just flashes until the light does out? if so the selector switch might be just it. Try turning the switch (with the ignition switch off) from left to right about 50 to 100 times, this will clean the contacts abit. not a perminet fix but if it works you just bought alittle time to go out and get a new one..
 
OP
OP
rjpoog1989

rjpoog1989

Well-Known Member
This whole ordeal has been an ongoing issue...

I will mention I don't have a trailblazer, or at least I don't any more... I have a GMC Canyon now.

4x4 has been working perfectly all winter long and then all the sudden 2 weeks ago I tried to engage and got nothing. I tried going forwards, backwards, neutral, neutral and rolling, and nothing. Seems like something might be overheating, as it only seems to not work when the vehicle has been running a while. Can a TCCM over heat?

Then the next morning it worked fine again and has ever since. Very odd...

To answer one of the above questions. I bought the vehicle in June, according to the dealer, all fluids including the transfer case fluid were changed before my purchase. I'm at 80,000 miles.
 

Online statistics

Members online
10
Guests online
376
Total visitors
386

Forum statistics

Threads
20,344
Messages
593,590
Unanswered questions
2
Answered questions
2
Members
13,377
Latest member
Wheelybar
Top Bottom