12' Silverado Defrost

Jason24

Original poster
Member
Jan 8, 2012
30
Problem #1 with the new truck :frown:
Driver side windshield defrost seems to work just fine, but the passenger side does not. Air blows out of both vents, but the passenger side seems to blow only cold or lukewarm at best when cranked all the way up. I have the digital automatic climate control. Are the blend doors for defrost separate for driver and passenger?

Jason
 

BO TIE SS

Member
Nov 18, 2011
1,497
Jason24 said:
Are the blend doors for defrost separate for driver and passenger?
See if there is a separate temp setting for the passenger. (I would think there is on an LT with digital climate)
 

Jason24

Original poster
Member
Jan 8, 2012
30
BO TIE SS said:
See if there is a separate temp setting for the passenger. (I would think there is on an LT with digital climate)

There are separate temp. controls for driver and passenger, but I'm pretty sure the passenger one deactivates in defrost mode. I will double check though.
 

Jason24

Original poster
Member
Jan 8, 2012
30
Jason24 said:
There are separate temp. controls for driver and passenger, but I'm pretty sure the passenger one deactivates in defrost mode. I will double check though.

I haven't personally checked yet, but according to the manual:

The passenger temperature control
cannot be activated while in
defrost mode. If the PASS button is
pressed, the button indicator flashes
three times and will not work. If the
passenger temperature buttons are
adjusted, the driver temperature
indicator changes. The passenger
temperature will not be displayed.
 

BO TIE SS

Member
Nov 18, 2011
1,497
Jason24 said:
I haven't personally checked yet, but according to the manual:
Have you tried increasing the temp of the passenger side prior to going in to defrost mode?
By those instructions, it sounds like you just can't make a change to the pass temp while in defrost.
 

Jason24

Original poster
Member
Jan 8, 2012
30
BO TIE SS said:
Have you tried increasing the temp of the passenger side prior to going in to defrost mode?
By those instructions, it sounds like you just can't make a change to the pass temp while in defrost.

No go under that circumstance either. The problem does however seem to be somewhat intermittent as it worked just fine this morning. I called the dealer and they are going to check it. I just hope the whole dash doesn't need to be ripped out of it.
 

Forum Statistics

Threads
23,330
Posts
637,983
Members
18,531
Latest member
MEHMET ONUR

Members Online