09 Tb 6CYL intermittent start

Greying

Original poster
Member
Mar 1, 2012
3
Sometimes my TB will not start, the radio losses settings etc. I boost it and away it goes. When it does not want to start, I can take the key out of the ignition. Today, I checked the bat voltage, sitting still, nothing on (that I know of) voltage was 12.02 to 12.06. With engine running, 14.2. If I leave the headlights on for 5 minutes, it will not start, What gets me is with the same routine, get up drive to work, park leave work start, it might or might not start.
I am suspecting a faulty battery, it is the original and does not seem to have any reserve. When it goes dead, it will not turn the motor over at all.

I am also curious to know if someone can tell me what part # 25826405 (module) does. It is located on the ground cables right next to the battery box.
Thanks
 

MAY03LT

Member
Nov 18, 2011
3,422
Delmarva
Greying said:
....voltage was 12.02 to 12.06....I am suspecting a faulty battery...

I'm with you on that. Usually I'd suggest a charge/load test but based on the symptoms I'd say it's time to replace it.

Greying said:
I am also curious to know if someone can tell me what part # 25826405 (module) does. It is located on the ground cables right next to the battery box.

The fancy name is the Generator Battery Control Module, although I have seen it referenced as the voltage control module. It monitors and controls the alternator output mode based on inputs from the pcm.
 

GCTB1289

Member
Mar 19, 2012
699
Yes definitely time to replace the battery
 

Forum Statistics

Threads
23,400
Posts
638,838
Members
18,614
Latest member
dakis

Members Online