Upgrading Rear View Mirror & Installing Additional Interior Lighting

rjpoog1989

Well-Known Member
Vehicle: 2005 GMC Canyon SLE z71

So I got a new mirror with auto-dim, temperature and compass. Wired everything up and the auto-dim and compass work, but the temperature reading is -26F and -32C which isn't right. I think the ambient temp sensor may be bad, I'm hoping it's not the mirror that is screwed up. I originally had a 7 pin harness but the mirror I got had a 16 pin, so I had to splice the and heat shrink the wires. Not hard after some research.

Original 7 pin harness:

Pin 1 = power
Pin 2 = ground
Pin 3 = reverse auto-dim inhibit
Pin 4 = temp sensor
Pin 5 = temp sensor
Pin 6 had nothing
Pin 7 = 12 volt constant

Took the grill off to access the temp sensor location and to access the wiring. I also removed the bottom headlight on the passenger side to access the wiring.

I was able to use quick connects from walmart to tap into the temp sensor wiring here

Installed the temp sensor (which I think is bad, so I may have to get a new one) here.



I bought a dome light from a Silverado because my old mirror had map lights, and my new one didn't. I still wanted lighting in the front seat area.

I wanted the light to go here:

So I cut a hole:

Had to remove two plastic thingys that hold up the headliner

I taped into the wires feeding into the oem dome light. (orange and white) These wires went to the orange and white wires on the new dome light. I fished the wires forward to my new hole with a metal coat hanger.


I took the black wire on the new dome light to the mirror ground (wire that went to pin 2 on the oem mirror). This allowed the map lights to function via the buttons on the light while the middle light comes on with doors open or with the switch on the dash.

This pic is with a door open and the map lights on as well.


Yes the mirror wiring in that last picture is still exposed. I will hide once I get the mirror to work properly... Any advise on that is appreciated, thanks for reading.
 
OP
OP
rjpoog1989

rjpoog1989

Well-Known Member
rjpoog1989 said:
So I got a new mirror with auto-dim, temperature and compass. Wired everything up and the auto-dim and compass work, but the temperature reading is -26F and -32C which isn't right. I think the ambient temp sensor may be bad, I'm hoping it's not the mirror that is screwed up.

Just wanted to update this. It ended up being a bad mirror, so I sent it back to the seller and got another one. The new one has been working perfectly since I installed it last weekend. This is a great mod! :wootwoot:
 

Online statistics

Members online
9
Guests online
360
Total visitors
369

Forum statistics

Threads
20,344
Messages
593,590
Unanswered questions
2
Answered questions
2
Members
13,377
Latest member
Wheelybar
Top Bottom