Trailblazer ABS codes C0035 and C0245

wormwood1978

Registered Member
Original poster
Jan 3, 2015
54
I just finished cleaning the throttle body and ran the ODBII for codes and it shows C0035, C0245 and C0455. I'm not surprised about the C0455 as it is the steering position sensor and I occasionally get the Stabiltrak light because of this. Perhaps one day I will change the steering position sensor.

So the C0035 and C0245 are left front wheel speed sensor circuit malfunction and wheel speed sensor freq error. Is it normal for these codes to show up together? I have not noticed any braking problem and my ABS dash light has not triggered. Should I leave this alone until I notice a problem? I saw a youtube video that shows how to do some troubleshooting with a multimeter rather than just blindly putting in a new sensor.

Any thoughts?
 

TollKeeper

Platinum Donor
Dec 3, 2011
6,401
Brighton, CO
The typical place to start is cleaning the sensor end. Remove brakes, rotor, and using a Allen wrench, take the sensor out, and clean it off. I've seen people use MAF cleaner on these with no if effect. Also check the wiring for kinks, rubs, breaks, etc.
 

Mooseman

Master Blaster
Moderator
Dec 4, 2011
21,832
Ottawa, ON
And is the wheel bearing making any noise? Have you ever had ABS activation at low speed for no reason? That's usually a problem with the sensor, the tone ring inside the hub or the hub bearing itself on its way out.

What year is your truck? The early trucks would just activate the ABS each time. My 07 did it once and threw a code to deactivate ABS (can't remember the code, could have been the same).
 
OP
W

wormwood1978

Registered Member
Original poster
Jan 3, 2015
54
Its a 2008 with 86,000. Aftermarket hub assembly at 45,000. I haven't noticed any bearing noise or low speed abs activation. I will likely pull the sensor and do some cleaning.
 
OP
W

wormwood1978

Registered Member
Original poster
Jan 3, 2015
54
I cleared the codes out on Saturday and after a couple trips and maybe 70 miles, they have not returned. I'm certain the steering wheel position sensor code will return, but it would be nice if the ABS codes do not. I'm wondering if when I cleaned the throttle body and removed a few fuses to force a relearn, it for some reason triggered the two ABS codes.
 

Forum Statistics

Threads
21,832
Posts
618,028
Members
16,070
Latest member
tsctossapol

Members Online

Members Online

Members Online